How to make key command "Project > Bring To Front" not beep?

I’ve assigned a key command (cmd-F3) to rapidly switch between mixer (F3) and project window. It works as expected, but every time I switch to the project window, there’s a “beep” (a system sound played).

Anyone knows how to make it not beep?

Hi,

You probably set this command to something on the system level. Check (Mac OS X) System Preferences > Keyboard > Shortcuts, please.

Thank you for the suggestion, Martin. I’ve now checked though all the System Preferences > Keyboard > Shortcuts listed for my OS but unfortunately I couldn’t find that cmd-F3 was assigned to anything.

I also tried to assign “Bring to Front” to other keys, with the same result. All the common letters are already assigned by default it seems, so the two I tried was “§” and the Swedish/German letter “Ä”. Both are single keys on my keyboard, and no modifiers. Same beep.

Hi,

What is the exact name of the function, you are triggering in Cubase, please? I don’t remember, there is a Key Command to switch between MixConsole and Project window. But I’m probably wrong. Thanks.

Under “File > Key Commands …”
Open the “Project” folder,
There is a command “Bring To Front” which I’ve successfully assigned to a key (cmd-F3). It does everything I want, but it beeps.

I also tried cmd-F3 in the Finder. Nothing happens, and it doesn’t beep. So it seems to me that Cubase is for some reason issuing an alert, but I’m not sure. Perhaps if someone else can try to replicate it, so we can se if it is consistent across (preferably El Capitan) installations.

Hi,

So your goal is to put the MixConsole to background and bring the Project window on top, right? You are not using it to switching MixConsole/Project window on top, right?

Wouldn’t be better to define own Global Workspaces and then just switch the Workspaces? This is the proper way, how to change the window layout on your screen in Cubase.

The command Project>Bring to Front is a proper way too. To the OP, have you tested with different keystrokes?

I’ve now tried with:
Command-Option-Shift-R
Command-Option-Shift-E
Command-Option-Shift-K

All with the same result. It fronts the project window, but beeps … (None of the above key-commands are assigned to anything in the OS X). I could continue and try more keystrokes, but it doesn’t seem to be the problem.

One keystroke was enough! :smiley:

Weird. Next time I use my Macbook I will try to reproduce this.

I used to have a Mac Pro 2008(!) with two 24" monitors. Project window on #1 and mix console on #2. When it went belly up I opted for an iMac. Now there’s only one screen, and I’m trying to adopt my workflow to cope with that. The only thing I really miss is to have both the project and the mixer windows immediately available without having to mouse over to the Window menu. The next best thing would be to have keyboard shortcuts to quickly toggle between the two. That would be sufficient, and that’s the goal.

I have actually already achieved that goal, although the solution included an annoying beep, which I’m now starting to think is a Cubase bug.

My goal with this post was to see if anyone knows why it beeps - is it intentional or a bug - and hopefully how to turn the beep off.

Well, certainly there is something causing that annoying beep. :confused:

In this use case, what Martin said initially really is the proper way to achieve that, and more. Have you experimented with Workspaces? You can assign keystrokes to them.

Thanks! That will be very interesting.

I’m more and more interested. I will also try it. :wink:

Thanks! That’s great.

Yes, I had a couple of workspaces set up on the previous system, and in response to your question I tried to make two that fronts either the project or mixer window. It doesn’t beep :slight_smile: but it works slightly different: It shows only the windows that are recorded with the workspace preset, closing everything else. One could argue that I can always get them back through “Workspaces > No Workspace”, but I prefer the other solution which only has effect on the project/mixer window. Lets say that I have 59 plugins open that weren’t accounted for in the workspace setting. They will be untouched in the solution I’m aiming for, but as I understand it all closed with a workspace command.

So Workspaces is close, but I’ll accept the beep to be able to use the other solution.

That said, I’ll probably be using Workspaces as well, but for other purposes.

I hear you. The Bring to Front shortcut is one of my most frequently used.

+1 Here i thought it was just me. I use “Bring to Front” to activate my project window when using key commands to navigate. Annoying having to grab the mouse just to activate a window. I do remember older versions that had Bring mixer to front or Bring arrangement window to front.

When you switch to mixer does it close project and open mixer and other way?

I have this problem with my lemur project ,I have key commands for the mixer but don’t do anything when on the project is in focus,and when mixer is in focus I can use the project commands without clicking on the project window…what I’m working on now is when opening the page for say mixer commands setting up a mouse movement and left click on a empty space to pit mixer in focus…lemur can send pixel locations for mouse and clicks,but I need them to run on page open,got to figure that out first,I could use the macro program and tie it to a kc ,but then I would have to tie them to all commands…pita!!