How to make VST Connect Pro work with LAN?

Hi all,
I just purchased VST Connect Pro 5 a couple of days ago, hoping to be able to use it with a few remote clients soon.

A few issues:

  1. On my end, in Nuendo 13, when I open the VST Connect editor, I do not get ANY Mixer faders in the mixer view. None at all. Even after setting up the Performer Rec channel, which is automatic and there, then the control room, talkback microphone, monitor 1, etc. I am online, logged in with mySteinberg credentials. The Mixer window says it is offline. My talkback mic is not showing any levels, despite in the tutorial video as the person is talking one can barely see levels in the CUE meters. My microphone is definitely on and quite loud going into my converter channel. If I create a regular audio track, I see and can record its signal, so that is not the issue here.

  2. I have a test computer connected to my network, to make sure I can understand and teach the client how to connect via the Performer application. Using the latest version. For this to work, do I need a SECOND MySteinberg account? Does the client need a MySteinberg account? What if they do not want to bother creating one, can they login anonymously? In the tutorial it is simply not clear what to do, at least to me. At least, I do see faders and levels in the Mixer window, unlike the one in Nuendo.

I’ll try reading the manual once more… what is missing here?

Any help is appreciated.

Specs: Nuendo 13.0.20 build 148 Intel Mac, VST Connect Pro 5.6.0.734, VST Performer application 5.6.0.734

I got my talkback mic to be seen in the Cue, by turning on a Cue Send in the Performer Rec channel. I see metering in the CR from my talkback mic now. Progress…

Sadly, the tutorial video is with Cubase from 3 years ago, some things are different now. Is there a more up to date tutorial with Nuendo 13 and VST Connect Pro 5?

I created a new test Steinberg account, for the second test computer.

It is now logged in, and I am “friends” with my regular Steinberg account. They “see” each other in the friends list, and they aere both light blue, connected.

I am still not able to send nor receive ANY audio between them. the Performer app states an error message “539 User not authorized”. Is this the issue? When I had no client account, this was still messed up, so I don’t believe so.

I am also NOT seeing any faders in the Nuendo side of the VST Connect pro Mixer in the VST Connect Pro Edit window. It still says “Mixer Offline.” Why?

Here are some screenshots of my setup:



SO I double clicked on my dummy test account in Nuendo VST Connect Pro, and it began to connect, but did not do so.

In the Performer Application, the test one, it states:

“Somebody tries to connect to you from within your local network. This is not supported.”

So Steinberg, HOW am I supposed to TEST this feature, for which I paid USD $119.00, if I CANNOT even make a dummy test connection on my own, and learn HOW to make this work?

LOL did I waste my money on this?!?

I tried doing a completely new VST Connect test session. Rebooted the computer.
Now when I create a new Empty Nuendo session, and I proceed to Create New VST Connect Pro, I get the following error message, belo in step 4

What is this all about?

This is what I am doing:

  1. Open Nuendo.

  2. Create a New Empty project, in its own folder, and save it with a new name.

  3. Go to Menu / VST Cloud / VST Connect PRO / Create VST Connect.

  4. I log in with my Steinberg credentials, and the blue online light comes on.

  5. I still do not see any faders in the Mixer Window of the VST Connect Editor.

  6. This error message appears now:
    Screenshot 2024-02-21 at 1.51.09 PM

  7. I still see a new Performer Rec track being created, and I turn on Cue 1 on that channel, and set it to record enable.

  8. Now, I no longer see my talkback mic signal! Even though the green talkback button is on in the CR section on the right panel.

Is this broken now? All I did was turn off the dummy client Performer application, since I cannot do this on the same network (really?) And then quit Nuendo, reboot the computer, and try to do a completely new VST Connect session.

What is happening here???

So Now I am reading the manual again, and it states that I can connect via my own internal LAN network.

It seems that I need an older version of VST Performer.
I downloaded version 4.0.45.514
Seems that it connect directly VIA LAN ok.
I sure wish Steinberg would help with compatibility between OS versions and Performer and VST Connect versions.

Let’s see how long this connection lasts…

I have two clients whom I still do not know what computer and operating system they have, so I am dreading having to go bonkers trying to get this to work remotely with them.

So now, I have talkback sound going to Performer, and I can hear the client microphone.

I also can playback a track from the Host Nuendo and it plays back in Performer.

However, IT DOES NOR RECORD ANYTHING in the Performer Rec track.

When I press the talkback button, the Performer mutes, as expected, and then when I turn off talkback, the performer mic turns back on.

I am getting NO metering nor recording of audio in the Performer track. I got a pop or two, like digital glitching one in over a minute of recording, but nothing else.

And now I find some audio tracks in the VST Connect Edit window, so I tell it to “get” them, and it lays them out into a NEW track. So the recordings are there. They are a Stereo track in the Performer Rec track, and a new folder labeled “VST Connect Pro” with a track inside it labeled “Perf. Mic”

But… while recording, there is no metering, no waveform, no indication that anything is being recorded. Empty clips, that get replaced once you “get” the HD tracks from the client computer.

Is that normal function???

I increased the buffers all around and the video and upstream to lossless, and was able to record 8 tracks at once.

Curiously, now when recording these, I do get a waveform in the single “Performer Rec” track. Still no metering, and NO talkback. In the settings of VST Connect Edit window, it states that there is “talkback channel - not connected.”

And the talkback is working as expected, only being heard over on the Performer application when turned on.

I do not understand how, in the first recording I did, there were no waveforms nor metering in the Performer Rec track, but then when I went to do it a second time, with buffers all larger, then I se the waveform, but also still no metering on the track.

Weird to me… could this be a function of the buffers?

Maybe this will help:

1 Like

Thanks. I did make some headway last night, but I suspect I am going to find more “issues” as I use it with different computer configurations.

We ended up making it work. I am just not used to having to have the network connection BEFORE having things like talkback and audio signal functioning. I come from the analog world, where we set up all the audio signal first, then piggyback remote connections afterwards.

Still, it would be awesome to SEE incoming meter signal in the Performer Rec track. As it is now, I only see it in the VST Connect Edit mixer window. So I have to have that open to see if the signal is clipping on there.

Is there a technical reason the Performer Track meters do not function?