how to paint high resolution automation ?

How can you make automation curves without it quantizing to the quantize settings of the editor ?

if I’m recording it by knob control and then trying to correct some parts manually, I hear stepping in cutoff automation (for example) and I’d like to know if there’s a way to have it paint the automation at a higher resolution without needing to switch quantize settings.


You can set the amount of data thinning from the automation panel. click the little star thing on the bottom left.
Also turn of snap I think?
And or press shift whilst drawing a curve.

Page 230 of the manual.

Turn Off the snap button (it looks lik this: >|<), or use Key Command “J”, in default, for switch this settings.

Or change the rate of your grid.

ok gonna try thx :slight_smile:

hmm it’s just better that I do it in the automation lanes rather than in the midi controller lanes. Automation just seems to interpolate between 2 keys.

Whatever I do (deactivate snap, press shift), the line tool will always quantize the keys so it starts to sound glitchy if you do that with a filter.

The conrete situation was this:

i had used a knob on my m audio keystation pro 88 to midilearn sylenth’s cutoff filter. It’s ofcourse very densely recorded if you do it that way and you don’t hear stepping at that point. BUt if I wanted to alter the sweep somehow because I found it more suitable to the song that it’s ab it diferent, when you start correcting it with the line tool it just keeps quantizing it.

The pencil makes lots of events too and doesn’t quantize but drawing with the pencil seems kinda unstable and I can never do a straight line with that.

I just decided to do it with vst automation.

But that still puzzles me; I find midi learn a great feature to automate stuff, but if you’re doing it on midi lanes it just seems hard and verbose to get a clean non quantized line.

You have to hold the ‘Ctrl’ key, NOT ‘Shift’, if you want to bypass your Snap settings. As already mentioned, you can also disable your Snap settings by pressing “J” on your QWERTY keyboard or by simply clicking on the Snap icon. The Line Tool shouldn’t be quantizing at all with Snap disabled. You must be doing something wrong, cause it works as intended here.

EDIT: Spelling.

I had the same problem and yes: deactivating snap by pressing “J” did the trick and I get very fine resolution in my controller lanes, probably at least 1/128.
I want to comment, that in Samplitude, where I come from, the drawing of controller curves is NOT quantized, at least not to the rough quantization that you usually have for your notes. So you can have 1/4 Q for your note events and at the same time, without pressing or switching anything draw smooth lines under the piano roll. Very handy…