How to permanently Disable Autoscroll

Hi there does anyone know how to disable Autoscroll permanently.Ive tried disabling it from menu at top right corner of Inspector but one I zoom in it starts to scroll again whenever I zoom in.Is there a way to permanently disable it

Aloha Steve,
I don’t use the Inspector to disable ‘Autoscroll’.

What I use is the ‘Enable/Disable Autoscroll’ feature in the left most position in the tool bar
on the ‘Project Page’.

Looks like a ‘striped’ arrow pointing left with a nail thru it.

And while we are on the subject,
I would like to be able change the position of the ‘Stationary Cursor’ to anywhere on the page.

But no, It is only ‘stationary’ in the middle of the page.

HTH

{’-’}

+1 for define position.

Thanks for this answer I use this to disable it as well but whenever I zoom in it reactivates again…

Autoscroll is enabled or disabled by clicking on the Autoscroll button on the toolbar. (You may be getting confused with ‘Suspend Auto Scroll when Editing’).

Thanks I click on the autoscroll button (yellow arrow icon) and whenever I zoom in it starts to scroll again

Also the key command “F” will toggle autoscroll on and off but not permanently.

As mentioned, you may be getting confused with ‘Suspend Auto Scroll when Editing’. With this active the autoscroll becomes temporarily de-activated while editing (in this case it is displayed highlighted in orange during playback). Using ‘F’ in this case (during playback) will de-activate the ‘suspend’ state but NOT Autoscroll. However, if you de-activate the normal Autoscroll button (when it is displayed highlighted in white) it is permanently disabled.

Just remove that F shortcut key, i always keep pressing it somehow and always autoscroll gets active, since I remove it from commands no more autoscroll.

You are probably dragging in the ruler to zoom in and out. Unfortunately, this particular technique will always de-activate the ‘suspend autoscroll’ state because it includes a mouse click on the ruler.

If you want the ‘suspend autoscroll’ state to remain while editing and zooming use the G and H keys or Ctrl + mouse wheel to zoom instead.

I am utterly annoyed by this as well! There is absolutely no reason why they should not add a “deactivate permanently” option…

According to Stingray …

However, if you de-activate the normal Autoscroll button (when it is displayed highlighted in white) it is permanently disabled.

yes, but for me it switches back on too…

@Marcopolo did you read the above posts? There are 2 things at play here, the first is the basic autoscroll state when the autoscroll button is displayed in white and the second is the suspended autoscroll state when you are editing and the autoscroll button is displayed in orange… as outlined in some of the posts above.

You may be getting confused with ‘Suspend Auto Scroll when Editing’. With this active the autoscroll becomes temporarily de-activated while editing during playback (in this case the autoscroll button is displayed highlighted in orange during playback). Using ‘F’ in this case (during playback) will de-activate the ‘suspend’ state but > NOT > Autoscroll. However, if you de-activate the normal Autoscroll button (when the button is displayed highlighted in white) autoscroll is permanently disabled.



You are probably dragging in the ruler to zoom in and out. Unfortunately, this particular technique (and possibly certain other techniques) will de-activate the ‘suspend autoscroll’ state (button displayed in orange) because it includes a mouse click on the ruler.

If you want the ‘suspend autoscroll’ state to remain while editing and zooming > use the G and H keys or Ctrl + mouse wheel to zoom instead> .

You might find your autoscroll button automatically switching its state is linked to one of the above points.

In addition, you might care to describe the exact circumstances of the issue you are experiencing. Without that precise description nobody here can really help you out. So I would ask you…

  • what are you doing exactly when the ‘autoscroll’ switches back on?
  • does this happen during playback or in stop mode?
  • what is the state of the autoscroll button (what colour is it) just before it ‘switches back on’ ?
  • are you talking about the suspended autoscroll state when the autoscroll button is displayed in orange or are you talking about the non-suspended state when the autoscroll button is displayed in white?

This is exactly what I do and then thats when the scrolling starts especially in the Key Editor.

“You are probably dragging in the ruler to zoom in and out. Unfortunately, this particular technique will always de-activate the ‘suspend autoscroll’ state because it includes a mouse click on the ruler”
This is exactly what I do and then thats when the scrolling starts especially in the Key Editor

Exactly… so therefore, while editing during playback and zooming, why not use the G and H keys or Ctrl + mouse wheel to zoom instead? It’s just a slight change in workflow but doing this completely avoids the issue.

I use all 3 methods of zoom. Generally, I always have the auto-scroller off and only turn it on and then off when I need to snap to the time position line. If you’re using G & H for zooming, F is right there to able or disable auto-scrolling.

I would LOVE a way to permanently turn this damn thing OFF. The fact that it switches itself back ‘on’ every time I use the mouse to zoom is MADDENING!

"I would LOVE a way to permanently turn this damn thing OFF. The fact that it switches itself back ‘on’ every time I use the mouse to zoom is MADDENING!
This is so true…Ive never used Autoscroll and Im surprised there’s nothing in Preference regarding this.