How to Prevent Delay FX Continuing to Sound on Song Stop

Hello,

I’ve had this issue as far back as I can remember through multiple Cubase versions. If I have delay effects (insert or send) that are sounding when I happen to stop playback, the effect(s) will continue to sound. Sometimes I use really long delays and they can take over a minute to disappear into silence. This happens with 3rd-party plugins and Sternberg’s built-in ones. Specifically I’m using PSP 84, and Cubase StereoDelay VSTs.

It really is maddening to have the sound continue when I’m trying to edit something or even just think! I have to keep muting the main outputs. The only workaround I have found is to manually turn off and on the plugins which finally shuts them up.

Is there a setting I need to turn on or off?

Please can someone help me?

Thank you,
Darren

System:-
Model: Mac mini Server (Mid 2011)
OS version: OS X 10.11.6 (El Capitan)
Cubase version: 8.5.20 Pro
Processor: Quad Core 2 GHz Intel Core i7
Memory: 16 GB 1333 MHz DDR3
Graphics: Intel HD Graphics 3000 512 MB
Storage: 250GB Flash (System HD), 750 internal SATA HD, 1TB external SATA, 2TB external USB HD, 5TB external USB HD
MOTU 828 mkII FW audio interface
MOTU MIDI Express 128 MIDI interface
Lots of VSTs.

No easy way to stop it that I know of…I’ve even tried changing to another audio driver and back and as soon as you select the correct driver you hear whatever is left of the tail.

I believe some other DAWs have the option to not play fx tails on stop.

Of course they will continue if they are long feedback delays.
The only way you could stop this is to render the tracks as audio or freeze the delayed tracks till mix down possibly.
Mike001

Yes, I think Logic respects the user’s wish to stop the music when he hits ‘stop’ and does just that. I simply cannot see the benefit of letting them continue (I guess there may be one I cannot think of).

At the moment, I’ve resorted to some automation at the start of my song that stops the effects in question, but it’s tedious to have to do this on every track that needs it. I then send the song position cursor to the song start and it silences the audio.

But, not ideal.

Why “of course”? It seems strange to me that this is the case.

As Grim wrote, it should at least be an option to turn off FX trails, as other DAWS do.

But thanks for the suggested workaround.

https://www.soundradix.com/products/muteomatic/