How to remove these rest without messing with the other notes


I am running into this problem. I am trying to delete a rest from the right-hand of a piano staff by going to Edit > remove rests. But then it deletes the cross-staff beam! ( please see attachment).

I’ve removed the 16th note rest of the second bar. Bars 1 and 2 were initially identical.

Would appreciate it if also someone explain why Dorico displays those rests?
Screen Shot 2020-09-05 at 7.30.15 PM.png

How did you input these notes? If you input the upper part on the top staff and then crossed the notes that you want to display on the lower staff by selecting them and pressing M, you shouldn’t get any extra rests. Unless your initial note (the first A in the bar) isn’t a dotted quaver in the RH part - making it a dotted quaver automatically gets rid of that rest (as there’s no rhythmic space for it)

If you really, definitely want it to be a quaver and not a dotted quaver, just manually rebeam the phrase after removing the rest.

This is what I did. It puts those 16th rest there because the next notes are doubled (C3,E3)? I used a single voice for the top staff as you can see.

Attached example.

What I did:
After inputting the soprano and bass notes, I crossed the ‘a’s’ in the soprano to the bass (M). I used the voice index property in Engraving mode to coincide the ‘a’s’ and then, back in Write mode, I removed the extraneous rests in the G-clef. This action created some unbarred notes. I selected those notes and with a right mouse click chose ‘beam together’ from within the ‘beaming’ submenu.

[attachment=0][/attachment] (565 KB)

I’m wondering what the purpose is for having the LH e doubled. This is what I get if I input one voice in each staff, cross-staff the initial A in the RH to the bottom staff and flip the A in the LH. The latter action sets the RH A into the first voice column index automatically to zero, providing your Notation Options are set up this way.

Cross staff.png