How to remove time signatures on only certain time signatures?


I would only like to have time signatures for the winds and the strings. How can I remove the others? They are small in this picture.

Try this. It might work (only a guess, though!).

On each of the staves within a bracket for which you want to hide the time signature (eg Horns 1 & 2), enter a local time signature using alt-enter. Then click on each of those local time signatures and enable “Hide time signature” in the Properties panel.

Tried this, didn’t seem to work.

After posting my reply, I tried it and it worked for me.

Did you do it this way? :
In Write mode, click on the first note/rest in a player (eg the A in the Horn 1 part), press shift-M (to open the time signature popover), type 3/4, press alt-enter. The large time signature for both horns should disappear and be replaced with a normal time signature on the Horn 1 staff. Click on that and enable “Hide time signature” in the Properties panel.
Also, it seems that you only need to do this for the top staff of those that are bracketed together, ie Horn 1, Timpani, Percussion 2, top staff of Harp (although if you remove the brace you will need to do each Harp staff separately).

Hey it worked that time! What a strange workaround. Thank you Steven!!
-Jonny

The important thing is to click on the note or rest immediately after where you want the time signature to appear, not on the time signature itself, unless it has been entered as a local time-sig (one which applies only to that staff) using alt-enter.

2 Likes

Engraving Options > Time Signatures > Time Signatures Centered on Brackets has different scale factors dependent on how many staves are in each bracketed group.

Set the scale factor for Two or three staves to 0 and you don’t need Steven’s workaround.

5 Likes

Great tip Leo, thanks!

I did this and am still running into problems. The time signature is gone from the percussion on the first page, but it appears for the rest of the pages. I tried Steven’s workaround on these and it will not work with these. Any further suggestions?


I have done some more experimenting to try to sort out why.
The procedure I described earlier does seem to sometimes behave inconsistently at the start of a new page and be affected by the presence of things such as system breaks and repeat barlines. One oddity was hiding a time signature but seeing both the time signature and the signpost (which is supposed to only show when an object is hidden). In this case, after saving the file and closing it then re-opening it, only the signpost was showing, which is the correct behaviour.
After some trial and error, I managed to eventually succeed. If you would like to send me the project (or put it into something like Dropbox and send me the link to that), I can have a look at it for you and see if I can achieve the result you want.

I have had a look at what @PianoLeo suggested:

Engraving Options > Time Signatures > Time Signatures Centered on Brackets has different scale factors dependent on how many staves are in each bracketed group.

Set the scale factor for Two or three staves to 0 and you don’t need Steven’s workaround.

If you set the scale factor for 1 staff to 0, that should make the time signatures on the Percussion 2 staff disappear.