How to remove un-used VST Instrument from Project

I can’t seem to remove un-used VST instrument and tracks from my project - there is no Remove Track option in the right-click context menu and Shift+Del does not work either.

The scenario:

  1. Open an old project that referred to a no-longer installed VST instrument
  2. It will generate an error whilst opening “The plug-in xxx could not be found for VST Synth 1!”
  3. I can’t see any way to remove the invalid reference to the VST instrument
  4. There are empty tracks that have a speaker icon that I also can’t remove

Screen capture included.

I’m running Cubase 9, Windows 10, (but the problem existed in Cubase 8.5 also)


These look like automation lanes. Is there an actual audio track above these that might be hidden? Check in the visibility tab.

Regards. :sunglasses:

Those are output channels and not tracks, if you remove the VST instrument that uses them they will probably disappear.

I guess the instrument is loaded to the rack (F11) so needs to be removed there.

If you want to remove a VST instrument go to the instrument in the rack (not the VST’s GUI), then click on its name, then select “No VST instrument”.

1 Like

Thanks for your reply, but none of these work. In fact, if you add a VST instrument, I can’t see any way to remove it? What do you mean “go to the instrument in the rack”?

It’s ridiculously convoluted.
Devices > VST Instruments (F11) > Left click on instrument > Go to top of column - “No VST Instrument”

Or simply highlight track > right click > remove highlighted track. Which of course only works with Instrument Tracks

If you want keep the midi files select No Instrument in the track inspector on the left.

Maybe it’s right click. If you have tried doing both one should work. I am not at my machine. If you are using C9 the 'rack’is the right zone. Go to the top right hand corner of the project window you should see an icon to enable disable zones. If its not there then you can right click the toolbar and ‘select all’.


Thanks DeePeeJay! Worked for me!