How to route 5.0 output to 5 separate mono tracks?

We’re trying to test the 5.0 output abilities of a VST3 plug-in we’re working on, but don’t have a surround audio system. So, we’d like to route the 5 outputs of the single output bus to 5 separate mono tracks, and record the results there. How would we do that? (We can use pretty much any version of Nuendo or Cubase for this.) Thanks!

Hi,

Add 5.0 Out in the VST Connections > Outputs.

Route the Instrument’s output to the 5.0 Out. Add a Mono Audio Track and set 5.0 Out Left as an Input. Add another Mono Audio track and set 5.0 Out Center as an Input, etc.

HI Martin,

That does not work. It’s what I tried right off the bat. In VST Connections->Outputs, I can add a bus and select 5.0 as the type, and in my audio track (not using an Instrument track, btw) I can route the output to that 5.0 bus. But when I add Mono Audio tracks, the Inputs for those tracks do not show the 5.0 bus at all, just “No Bus”, “Stereo In”, and inside that tree there is “Left” and “Right”.

Our audio effect plug-in takes either a mono or stereo input and outputs to mono, stereo or 5.0. It does not seem to matter whether I use a mono or a 5.0 Audio track to host the audio file I am testing with. The results are the same as I described above, with no way to get access to the 5 outputs. And I notice when debugging that the pug-in is never asked for a 5.0 output setup, only stereo. Perhaps this is because I do not have a 5.0 audio interface attached? Could Cubase be seeing that and refusing to show the 5.0 bus as an input, (or are busses defined as outputs simply not usable as inputs)?

Hi,

Make sure, you are not using this 5.0 Out bus as an output of the new Audio Mono track. You have to use another output. It means, you have to add even another output to your VST Connections > Outputs.

Do you have Cubase Pro? This feature us Cubase Pro only.

Hmm, I’m confused now… I have four parts in the chain now, if I understand you:

A) The first item in the chain is the track with the (mono) audio file and my effect plug-in on it. Should that be a mono or 5.0 track? Does it matter? Remember that I need Cubase Pro (or Nuendo) to tell my plug-in that it expects a 5.0 output bus arrangement.
B) Some kind of bus. What kind (mono or 5.0), and how many?
C) Another bus or buses. What kind (mono or 5.0) and how many? I assume 5 of something, since it feeds…
D) Fiveseparate mono audio tracks.

Have you actually done this, by the way? I can’t seem to find any combination that both tells my plug-in that it expects a 5.0 output bus, and allows the audio output from the plug-in to record on the 5 mono tracks from the five channels of that 5.0 bus (however many levels of indirection I use).

I am buying a 5.0 USB audio interface so I can test with that and see if it enables my plug-in to output 5 channels. But I’d still like to route the audio to mono tracks if I can.

Hi,

VST Connections > Output

  • 5.0 Out - You will route your 5.0 track (with the plug-in) here
  • Mono Out (or any other Out it doesn’t matter) - you will route your Mono track here. His other Bus is here, because you cannot use the same bus for an Input and also Output of the track, to prevent loop and feedback. In fact, it should work the same, if you set “No Out” in the output of the Mono Track.

Tracks:

  • 5.0, In (Not connected or what ever); Out to 5.0
  • Mono 1: In 5.0 Out Left; Out Mono Out or Not Connected
  • Mono 2: In 5.0 Out Right; Out Mono Out or Not Connected
  • Mono 3: In 5.0 Out Center; Out Mono Out or Not Connected

I’m still not having any luck. I’m attaching a couple of screen shots that might help show what I have.

The first shows the VST Connections window, and the mixer setup for the 5.0 audio track (on which I would place my plug-in). The second shows the mixer setup for the first of the five mono tracks, showing it getting its input from the 5.0 Front Left. But I don’t see anything getting to the mono tracks when I hit play. What am I doing wrong?
Screen Shot 2016-10-19 at 2.19.27 PM.png
Screen Shot 2016-10-19 at 2.33.36 PM.png

I was testing your exact scenario, now. And I found, it’s not possible to use Input of other channel format. So for Mono track, you can set just a mono Outs, as an Input, not Stereo or 5.0 Outs.

In this case, I would recommend following:

  • VST Connections Outputs > Add a Mono Out.
  • Add a Mono Audio track. Set Mono Out as an Input. Set No Bus as an Output.
  • Route your 5.0 Out to this Mono Out. Double click to the Panner of the 5.0 Audio track > MixConvert V6 appears. Show Input Channel display by using <. Click to the Left-upper triangle = Solo Left Channel.
  • Record the Mono Track.
  • Add another Mono track, set it the same way. In the MixConvert V6, disable Solo Left Channel, and enable Solo Center.
  • Record.