How to save midi mappings with the project Cubase 12


Could someone please give me a very concrete step-by-step walkthrough as to how to save my midi mappings in midi remote?

I am working on Cubase 12 and using AkaiAPC40 MKii and also an old M-audio Oxygen 49 as my controllers. The mapping goes fine, but when I re-open the project, all the mappings are lost. I have exported the script and when I reload it, it does not remember anything. So practically I should do all midi mapping from the scratch, whenever I open a session, which of course doesn´t make any sense.

I´m sure I am missing something very simple here. Please, if you could kindly help me out?

Best wishes, Iiro

Hi, there is no special thing to do. Upon changing assignments to controls, they’re saved automatically.

This one has a dedicated script published with CB12. Do you use it, or did you create a new custom one from scratch?

You shouldn’t face such problem.

Not sure I understand. As said, no special thing to do in order to save. Why using the export function? This is cool, when we want to keep a back up or share our script with others.
But then again, how are you implementing your remote? Using the assistant or by scripting?

It would be useful to post some screenshots of your remote manager (both tabs, midi remote and scripts) and your active remote devices’ UIs here.

@m.c Thank you very much for your kind reply. I will try my best to clarify. As backround info, I am quite experienced with Cubase, but as to midi remote and midi mapping, I am a beginner. I will attach screenshots, but I will also try to explain verbally:

Akai APC40MKii has a dedicated script, that is correct. I am using that. Cubases recognizes my Akai instantly, all good. As default, Cubase recognises certain Akai`s controllers as QC-controllers and assumes that the Akai faders are used for channel volume. This is fine. This is the situation when I open up Midi Remote, before doing anything else :point_down:

I then assign some of the other encoders to do things that is not already premapped in the Cubase´s native script (for example to control the EQ of the active channel). I also map things so, that I use some of the Akai´s pads to turn on the write / read -automation. Some pads I map to do jump to next channel, jump to previous channel, and so forth. These are my own assignments (mappings) and do not come with, but also do not overrun the Cubase`s own script for Akai APC40 MKii.

All the preceding things I do in Midi Remotes mapping assistant. However, after I close the session and reopen it, the following happens: Cubase still recognizes Akai (naturally), but does not remember my personal mappings that I just made. This is the problem. All my personal assignments are lost after I close the session.

I am convinced that there is a misconception here on my part. In Ableton Live, for example, I never run into this issue, because as to mapping everything there is 100 % intuitive and always saved with the session. I appreciate all help I can get, I am sure I am doing something wrong.

I noticed, that the AKAI script is - for some reason - saved as “local” (see the screenshot in my next message).

Greetings, Iiro

Here you can see the Akai script as “local”


Sure, because if I understood correctly, you’ve exported and then imported the script. Imports are done in the local folder, not in the public which is read-only.

However, this is not the cause of disappearing assignments. The cause is that you again export and import the script. Upon exporting, the manual assignments done by the mapping assistant are lost, because they are in a file outside of the script’s folder.

So, there are two ways to go from here:

  1. Continue using the script as now put into the local folder. BUT, please, don’t export/import. Just do your mapping and close Cubase. Upon re-opening the assignments should still be there. If not, there is a corruption.

  2. Delete the script from inside the MIDI remote Manager. Don’t worry, after that, and by clicking the refresh button, the original script which should be in the Public folder will reappear. Work on it, and again, don’t export/import.

1 Like

@m.c You are absolutely right! I actually figured this out last night by myself. I had overcomplicated things by messing with the import/export script -commands. After I last night manually deleted the previous file from the local-folder, everything works nicely now. More intuitive and simpler than I had assumed.

Thank you so much for your time and insight.

Greetings, Iiro

1 Like