How to set activeWorkspace when starting Wavelab

Can anyone confirm how to set the active workspace upon opening Wavelab 7?

In other words, if I always want the audio montage workspace to be the active workspace when I open Wavelab, how do I do this?

Also, if I want to have a specific set of workspaces open upon startup (say, for example, the audio montage and the audio file workspaces only (no batch processing or podcast, for example) and want to have a specific workspace be the active workspace (say, the audio file workspace, for example), how do I do this?



The last active workspace is restored next time you launch WaveLab.

For the second question, I plan to add a command line option that would allow to start WaveLab with a give layout (specifying the layout as the command line argument). For the time being, you could use the Master Project function that load a multi layout. That is: given a desired layout, save it in the master project. Later, you can open the master project, and restore that layout. You could create several such master projects.

I would like to request that this be changed to an “option” that we can disable or make an option available when we build/save a specific workspace - that specifies “Load this workspace at Startup”.

The way it is now is a complete pain…since I am still in exploratory mode - I am trying all sorts of different things as I feel my way around - and if I leave the program in one these states - I always have to plod thru the menus to reload my specific workspace for “work”.


Thank you for your response, Philippe. Good to know that you are planning an option for the “set of workspaces” question #2.

My experience on question #1 is that Wavelab always opens in the batch workspace, regardless of whether that was the last workspace I had open or not. Can’t get it to change this behavior.

Is there perhaps a preference file that needs to be trashed or something of that sort? Not sure why the program is not behaving as you describe.

@mardow: are you on Windows or Mac?

I use both Mac and PC, but I’ve been using PC mostly and haven’t checked this problem out on the Mac.

Running Wavelab 7.1 on Win 7 x64.

bump …

I don’t know what to say. Here when I quit with the Montage workspace active, this workspace is activated next time WaveLab is launched. What exactly happen at your place?

For me, the active workspace upon startup is always the batch workspace, regardless of what I was last using. I have the “open last window layout on start-up” checked in Global preferences, but this doesn’t seem to make a difference.

I’ve also noted that about 50% of the time, Wavelab 7 doesn’t shut down cleanly. If I shut down the program then attempt to re-open it, it hangs and never makes it to the splash screen. I’ve checked the state after shutting down (before attempting to re-start) and in the Task Manager it indicates that there is still a Wavelab process running, so it seems that Wavelab’s exit is not total. This problem, however, does not seem to have any correlation to the window layout problem – the behavior of the window layout is consistent whether Wavelab exited cleanly or not.

Unless there is some other preference I’m missing and haven’t set correctly, I think I’m going to uninstall / re-install and see if that clears things up.


What you describe could be the sign that WaveLab crashes always when quitting, preventing the active layout to be saved and later restored.
If you first close the batch processor, then quit WaveLab, then launch WaveLab, do you see the WaveLab batch processor again?
BTW, I assume you are using WaveLab 7.1 (not 7.01)