How to set bank MSB C00 for certain ext. synths?

Hi folks,

I’ve been scouring the manual and MIDI device pdfs for a more explicit answer to this, but I couldn’t find anything that worked.

Most of my synths use bank change CC32 (bank LSB) to change banks, and so they switch just fine using the Cubase inspector. The Shruthis, however, now use CC0 (bank MSB) for bank switching, and so don’t respond to the inspector bank changes.

Is there a way to force Cubase to use the MSB format that the Shruthis recognise, just for the Shruthis only, while keeping everything else the same for the other synths? I’ve tried setting patch change info in the MIDI Device Manager, setting the structure of the patches to follow a MSB bank change then patch change, but it isn’t reflected in the inspector for some reason.

Please can anyone help?

There’s a couple of things…

  1. Put the CC0 code in a midi part at the start of your project. Prob here is that you’re no longer using the inspector, so midi device patch lists won’t work for you. Program changes will tho.

  2. Use a midi conversion tool to translate the CC number just for that one channel/output. Prob here is to find such a tool. In the past I’ve used a virtual midi cable tool to patch in MidiOx which I’ve then used to filter out the default CCs which Cubase chases (because they can’t be turned off and they effect my external synths in unwanted ways!). Its a pain to set up, but in my case it was a joy to use once sorted :slight_smile:

Can’t think of much else, might help you though…


Thanks for the tips, Mike. I was hoping to avoid workarounds, but if there really are no other ways around this.