How to set initial window layout?

Does anybody know how to set up which windows (MixConsole, Transport, etc.) get opened when the program is first launched? And how to have the active project workspace save and reopen when the project is saved and reopened?

I always mix with the mixer fullscreen on monitor 2, with no other windows open. Yet, no matter what I do with workspaces, EVERY FLURBING TIME I restart the program and reopen the project, the transport panel is open and the mixer is gone. Why are my settings not getting saved/restored?? This was never an issue for me pre-v7.

(And–possibly related–does anyone know how to include full-screen MixConsole in a Workspace preset? It only seems to work when it’s a non-fullscreen subwindow of the stupid MDI parent window…)

+1

I would love to know the answer to this as well.

I just use my hot key on my Nektar controller to bring up the mixer but it’s still rather annoying,’’

C7 newbie here, and I’d like to say that I find the manual really lacking when it comes to talking about window management. I can’t get the different midi editors to open in a separate window. There must be something elementary that I’m missing.

Ideally I’d like to have a window set with the project window on monitor 1 & Score editor on monitor 2. Am I asking too much? :open_mouth:

Same here. Workspaces is one of the many annoyances in C7 dual monitor setups, they don’t seem to like working properly after being saved with a project.

Hope they will in .06 along with improved main/second monitor focus issues.

Cubase is one of those things where–at any given time in its development–it does 40,000 things really well, and about ten things really poorly. Window management is one of the ten things, and has been for a while.

It’s currently a horrid hybrid of true floating windows (which are nice, and more or less standard for modern DAWs) and “trapped” child windows that have to stay in the main “parent” window. Which functions can be shown in which kind of window is totally arbitrary. Having, say, the project window maximized (a pretty common practice) means that any time a non-floating window (such as the fade dialog that I use all the d*mn time :imp: ) gets opened, the project window gets de-maximized, which is really really annoying.

I was hoping that this was going to get fixed in C7, but they obviously had their hands full with the complete redesign of the mixer, which (aside from a few quirks and initial bugs) is a huge step forward. (INSERTS AND SENDS VISIBLE AT THE SAME TIME! YAY! :smiley: ) They’ve said they’re working on updating the project window as well, but I don’t know if that includes a re-think of the windowing scheme or if they just mean matching the look/feel to the mixer so that the controls/context menu options/etc. aren’t so different between the two zones.

Everyone always says the solution is to “just spread the main window across both monitors and drag the windows to the edges of where you want them”. That’s good and well if you have two identical monitors sitting next to each other. I have a 15.4"-screen laptop and a 24" secondary monitor, so the workaround doesn’t work for me at all. I want one screen to by FULLSCREEN, ALWAYS-ON-BOTTOM project window on one screen and FULLSCREEN, ALWAYS-ON-BOTTOM mixer on the other. Everything else should float on top, and I should be able to save any configuration of windows as a workspace, whether or not they’re in some stupid parent window.

That’s in a perfect world. In the meantime, I should at least be able to save a workspace as basic as [Project Window, MixConsole, no other windows], but I haven’t been able to get it to work as of C7.

This is supposedly fixed in the upcoming 7.06 … I hope so, but it’s more likely it is only semi-fixed. My money is that it will still not work with multiple monitors of varying resolution.

Monitors.jpg
Just to state what I have setup that seems to work quite well. I use two $80 AOC 1600X900 monitors for project window. Same models/size running from ATI Radeon HD 5450. The third monitor is a bit larger monitor, that runs from the Intel video driver on my motherboard. Mixer in full screen monitor 3.

No issues with windows setup or size.

I understand users wishing to be able to adjust for existing monitor sizes/resolutions, but it is much easier and not necessarily expensive to get two of the same monitor to solve the issue. :slight_smile:

Jimmys69

That is nearly identical to my 3 monitor setup the only difference is the graphics card…AMD radeon 6770HD and I’m using Dell monitors. The mixer on monitor 3 is from the intel video on the motherboard.

If you have your mixer full-screen on a third monitor that is different from your others, perhaps you know the answer to my question. Did you do anything in particular to ensure that this was restored when you reopened the program and/or specific projects?

I have a single 1st monitor (like your pair of 1st and 2nd) and a large 2nd (like your 3rd), yet my layout is never correctly saved and restored. Is there a trick to this?

Monitors 1 and 2 have the project window stretched across them. I usually use the project window on only on the left, and place plugs on the right. It stays setup the same as it was the last time Cubase was closed. If you were to use your 2nd monitor as full screen mixer only, you would still need to hit F3 every time you open Cubase. I do with my setup. Other than that, no special setup. I am not sure if it has anything to do with using 2 separate video cards.

Works great huh?

:smiley:

That answers my question.

Steinberg: now that there is a full-screen option for the mixer (thanks for that, btw!), will it ever be able to be stored as part of Workspaces? (I know it stores/recalls correctly as an “always on top” floating window, but not when it’s “full-screen”.)

Careful, incoming noob question:

I read through a few posts and used the search engine but none of that seemed to help.

My question is pretty simple: How can I have my arrange page on one screen and my mixer on the other?
When e.g. I click windows - mix console and try to drag the mix console over to the other screen, its either spread across both screens or its just on whichever screen I drag it to - This is fine but then I only have the mixer open. I only seem to be able to either have the mixer open or the arrange page but never both at the same time because in Windows 7 Cubase only shows up as one window, not separate (e.g. one window for the mixing console and one for the arrange page).

Help would be greatly appreciated.

Regards,

Jeremy

P.S.: I’m running Windows 7 64 bit

I think you just right click on open space on mixer to pull up menu. Click on Mixer full screen monitor 2.

@ jimmys69:

Thanks alot! That did the trick. My only problem now is that stuff on the top right is missing. (It only goes as far as “Link”… Is that to do with the resolution of my monitor?

Regards,

Jeremy


Update: It was to do with my screen resolution, all sorted now! Big thanks :slight_smile: