How to set "Play As Written"

Hello I’m wondering if I can ask for some help with something that is not very clear to me.

What I want to do is record music into a part with a MIDI controller but then have it played back “as written”. As is now, Dorico will transcribe my MIDI input to set quantization limits but will still play my horribly sloppy performance back at me when I listen. I seem to remember in Sibelius there was just a single button to toggle “Play As Written”.
I’m pretty new to Dorico and trying to figure out how to do this. The method(s) I’ve found so far to set this seem kind of vague… like sort of workarounds to me.
Maybe I am missing something? Any pro tips and/or tricks would be greatly appreciated.

Thank you so much!

Try selecting the notes and removing playback overrides - by default Dorico keeps your recorded played durations, as this allows you to have the option of subtle differences in performance with a neater notated version.

Are you saying you want to quantize the playback to reflect the written notation? That is possible. If so, check out some of these links.

Thank you very much for your replies.

Ah, remove playback overrides.

This was the solution I had found on my own but I was confused by the meaning of the phrase “removing playback overrides”. It seems to me to be something you’d do to undo the action made to force Dorico to play something as written. i.e. stop overriding the original MIDI file.

In my mind the MIDI file I created when recording into Dorico was the foundation of the part. Dorico transcribes it as close as it can within limits and writes it up in a part. It still plays it back the exact same way that I recorded it which is good because preserving the original performance could be important. In this case, having Dorico play the part back “as written” to me was how you’d be overriding the playback.

I guess I have to flip my thinking the other way around. Forget that the part started with me recording a MIDI performance into Dorico. Once a written part exists—the written music becomes the foundation of the part. Therefore a “playback override” is anything that causes Dorico play something back in any way that deviates from the written music (such as the MIDI file I created when recording into Dorico). So then to remove that “playback override” is to revert to playing the score as written.

I think I understand it now.

Try turning off Preferences > Play > Recording > Preserve Note Positions. I’m hazy as to whether that’ll actually store the recorded MIDI in such a way that you can requantize if necessary, but as long as you’ve set appropriate quantisation preferences in the first place that shouldn’t be a problem.

See my summary of these options here: can I quantize underlying Real-Time-MIDI-recorded data easily after the fact? - #5 by PaulWalmsley

The main 2 use cases:

  1. If you use MIDI recording just as a means of getting notes into the score, you probably want ‘Preserve note positions’ and ‘Preserve note velocities’ off
  2. If you use MIDI recording to capture a performance and you want to hear the same timing and dynamics during playback then set the Preserve options to on.

The ‘Remove Playback Overrides’ function is for the case when your preferences were set for option 2 above, and you’ve recorded via MIDI, but now you realise that you want option 1.

2 Likes

While we’re on this subject: here’s hoping they will eventually offer the equivalent of a “quantize strength” option so you can specify how close to perfectly playing as written you want the underlying MIDI to be re-quantized after the fact (as is standard in DAWs)…

  • D.D.