How to set up iZotope RX MONITOR

I just can’t get monitoring to work on my new build.

Win 10. Ryzen 1700. RX 4 advanced.

The monitor plugin can be instantiated on an audio track, group or FX. In any of those I can get it to show “connected”, but never to pass audio.

Nuendo 7 and iZotope RX have both been given network access in Windows.

Pretty fed up with these two companies at the moment.

I have the same problem, with RX 6 and Cubase 9.5.20.
Shows Connected on RX Monitor, but RX 6 gives an error.

Works fine here.
Don’t forget you have to put the Monitor plugin on an FX track.
According to izotope it only works on an FX track.

On my system it also works perfectly chosing my ASIO driver. So no need for the Monitor plugin.

Fredo

On Nuendo 7 with Windows 10?

Again: I tried that. It doesn’t work.

PS: I am now bypassing the plugin as you suggested, as I found a way of doing so. Inconvenient, but workable.

Hi @MattiasNYC

It does work, but contrary to iZotope’s suggestion you need to insert ‘RX Monitor’ plug-in on Audio Track instead and activate Monitoring (the little speaker icon). If you don’t see it, you need to add it in your ‘Track Control Settings…’

It appears that iZotope haven’t tested their own software with Nuendo/Cubase.

Best of luck!

Thanks.

That post is almost three years old and I got it working since then. I don’t have it on an audio track though. It works fine.