How to set "virtual midi"

Hello!

I have probably missed something but i can’t set the midi connection of a midi track to “virtual midi”.

I d like to use some gagareband keyboard sound with some midi notes created by cubasis and then import the GB file unto Cubasis. So I need to have a midi out connection to my cubasis midi track set to “virtual midi”. But nothing happen when i try to change the inspector’ track “midi connection” (I’ve tried tap, double tap, slicing).

Could please somebody 'help?

Thank

Fred

I have found that this control is sometimes a little unresponsive but you should just be able to tap on it to cycle through the available midi connections. Make sure you are selecting the midi out not the midi in, i know it sounds obvious, but i’ve done this before now! Also in Garageband, you need to open the instrument you want to control before it will respond to midi data.

Now all we need is for Garageband to get on the Bus!

Yes thank you. I understand that to set the virtual midi outpout there is nothing else to do that tapping in the inspector. And that a first step.

But I’ve tried to tap, double tap, close cubasis, reopen it, retap the inspectors midi connections, but the thing remains to “no connection” or something like that, for both of the midi connections (in and out). I’ll retry tonight maybe it’ll work this time.

Agree with this, garage band with the bus will be great. Combining with Cubasis : best of both worlds.

Still not working, i really don’t understand what’s happening with this midi connections control. My fingers not so big nevertheless…
I’haven’t tried with audiobus (still not get it yet) but i’m afraid that will be the same.

Hello,

on my iPad it works. I did the following:

  • Open Cubasis and create new project with a MIDI track. Ensure that “Background Audio” is activated.
  • Open Garage Band and ensure that “Run in Background” is activated.
  • Switch to Cubasis and add a MIDI track. Unload the internal instrument of Cubasis. Set the output of the MIDI Track to “Virtual MIDI.”

Result: When arming the MIDI track and playing on the internal keyboard, I can hear the instrument of Garage Band.

  • Record something on the MIDI Track in Cubasis.
  • Switch to Garage Band and start the recording.
  • Switch to Cubasis and start playback.

Result: Garage Band records the notes from Cubasis.

Sometimes I had to reselect the instrument in GarageBand to make the notes audible and the whole connection seems a little “shaky.” Does this process work for you?

Kind regards,
Frieder

Hi Frieder and thanks for that complete procedure.

My problem is at this step : “Set the output of the MIDI Track to "Virtual MIDI.” I can’t do this because the control of the inspector “midi controller” doesn’t change at all. It is suppose to have several possibilities (and virtual midi at last, which could effectively be usefull with garage band) but my controls remains at “no connection”.
The track is a midi track.

i’ll try in the order of your description, maybe…

Hi Fred, it sounds to me that you know what you are doing and that for some reason Cubasis is not behaving as it does for most of the rest of us. But as to why, I have no idea, sorry.

Hi here!

Yes i was thinkin the same way too and i was wondering what’s different from most of user with my ipad. And so i sometimes use a alesis io dock (an audio interface for ipad with real midi connections) for my audio recording.

Then Today i’ve tried once again, but with my ipad connected to my alesis io dock this time, and the midi connection control of the inspector track finally works. So i can put it to virtual midi at last. If i disconnect the ipad from the alesis dock, it returns to the original state : impossible to change this control.

It’s maybe some kind of bug caused by the combinason alesis dock/cubasis because virtual midi is precisely supposed to replace real midi connection, no? So it should’t need a real midi connection to be set up to?

Well i havn’t try yet with gb but i’m sure that 'll work as long as i keep my ipad on the io dock.

Thank a lot for the support Frieder and Phil!

This should be reported as a bug - but at least you have a way to get around it in the short term.

@Fred Have you tried resetting your ipad by holding down the power button and home button simultaneously?

Grasping at straws…
In iPad settings, general do you have multigestures turned off? Do you have any of the accessibility options turned on? Not sure if they would make any difference but this problem is strange.

Hi Surfer and Mgmg!

I have tried to completely close my ipad and reopen it, and not just reset it, but i’ll try just the reset option like you suggest it. I’ll also have a look at the general setting. I dont have my ipad right here so i’ll let you know ASAP!

That’s hold down power and home simultaneously until you see the Apple logo appear. I always do this before working with Cubasis. I also have the habit of putting it into Airplane mode before working with music apps.

I have made a little tutorial that might help. It’s about SampleTank integration but covers pretty much the same issue

http://www.youtube.com/watch?v=LIXYQcFI8VU&feature=youtube_gdata

I hope it helps

Nice video. It will be so much smoother when Sampletank gets Audiobus!

Hi everybody,

Despite all of the advices (resseting, general settings), still not working.

Trussrod, my problem is around 1:48 of your video, nothing happens while touching the midi connection control on my ipad. The only solution for me is to put my ipad on my “alesis io dock”, and then this control rebecome effective.That 's not very convenient by the way.

Like said before, it’s a bug probably due to the use of the alesis io dock with cubasis.

Hello FredB,

I wanted to let you know that we were able to find and fix your issue. So with the 1.2 update everything should work as it should.

Kind regards,
Frieder

Even though I am not really involved I would like to take the opportunity and thank you Frieder for the ongoing support. Good to see that Cubasis is beeing given all this attention though it is “just” an app. Looking forward to v1.2, hoping it will feature some of the community requests :mrgreen:

Yes, that´s a great news, so i’´ll look forward for the 1.2! I didn’t know that you were thinking about that special (and probably no so common) matter, i’m impressed!

I’m sure there will also be lot of extra awesome features.