How to Solo/Mute track from Editor? Solo glitch? bug?

First of all i have problems Muting/Solo tracks when im in the key editor. Solo is routed to the Solo editor and Mute wont get past the selected Key Editor window. Was working fine in Cubase 5. But the bug is still there.

If you want to replicate the “glitch”, not 100% if it should act like that and if someone can Confirm;

  1. Make sure Link Editors and Auto Select Events under Cursor are selected.

  1. Make 2 midi tracks and make an event for each of them with some notes in them.
  2. Open Key editor on one of the tracks, enable solo in the editor and play it back.
  3. Switch track in the background while keeping the Key editor on top.

Result =

Sound is stuck coming out of the other track than the selected one.
You have to click the Solo Editor button for it to update.

If you switch between the windows and go back to the key editor it will will update again correctly.
You can even go into the Preferences of Cubase from the Key Editor and close it and the sound updates correctly.


I dont understand why they havnt made the Solo Editor button affect the part you have selected in the Key Editor, its obviously meant as a Solo for not having linked editors. Should work that way when you have multiple parts in the Key Editor and keep the Solo & Mute track controls away from the Key Editor so we dont have to switch between windows just to Mute a track…!


I try this. The problem is, the Solo is affected by activated window.

So, you have to switch (in the Project Editor) to the track, you want to display in the Key Editor (and listen as Soloed). Than You have activate the Key Editor window. Than, you can start the play back. If you start the playback during the Project window is activated, it sounds al tracks. If it is play back, and you switch to the Key Editor window during the playing back, Cubase doesn’t mute all other track imedietly. All sounding notes are finished.


I switch tracks with key commands, not mouse Martin. So i have to go back and forth between Key Editor and Project Window to solo tracks. Project Window then overrides Solo Editor and i end up with sound on all channels.
Its just because Solo Editor is window state dependant.

Biggest issue i cant solo or mute tracks from Key Editor if its not CC. Why?

Personally, I wish single track soloing was automatable-or maybe it is, but I’ve never been able to figure it out, if so.
Occasionally, I just want to hard mute everything and just have, for example, the piano playing solo in a large mix full of tracks.

I know you can do it with groups and mutes, but it wold be nice to just write the automation.

I think you can clear all tracks from solo/mute and then solo selected… if you understand what i mean. Set up a macro would probably work. I havnt got into that yet, but definetly a hard mute is most natural thing and it should be easily accessible.

if you want to preserve your channel settings (mutes and solos) i think you have to route it, maybe you could set up a monitor track and set up a macro to switch its outs to it, its software after all i dont see the limitations of the hardware side in it.

im going to find out how to send midi cc from my pc keyboard and build macros around it, it got me around not being able to solo from the Key Editor and i bet i will end up against the wall with some other thing in the future and i believe you can do anything with a macro keyboard to work around the gui. not being able to solo track from the Key Editor limits me too much, look into scripted keyboards if your daw cant do what you like and the mouse routine just breaks your flow, most of the time you can build your own 1 key command routines which really boosts the workflow.

The way I do it (which is probably dumb but I haven’t figured out any better way) is select all tracks in the mixer other than the one I want solo-ed, assign them to a group and mute the group when I want the solo, but that seems so backwards.

at least if you select the part you are wanting to solo in the project window and hit enter on it you have the Solo Editor button on that. not sure if that works for you.