How To Stop Transmission Of Midi Control Change Messages

I have a 5 part midi song recorded in Cubasis 3.5 (latest update-iOS 16.2) which midi tracks are respectively assigned to and transmit to individual zones/channels on my keyboard. For example Cubasis Track 1, a piano voice also transmits to/plays Zone/Channel 1 on my keyboard, also a piano voice. But although I set keyboard channel 1 volume to 127, which is what I want, when I start playing the MIDI song on Cubasis, the volume on that Channel/Zone 1 on the keyboard is automatically reduced to 52. Usually this happens when I start the song, but always when the song repeats. I checked with the keyboard manufacturer and this is not a keyboard problem. So evidently Cubasis is sending out a volume control change midi message. SO HOW DO I STOP CUBASIS FROM SENDING OUT THIS MIDI CONTROL CHANGE OR ANY CONTROL CHANGES? When I double click on the track and the editing window opens, there is a list of parameters on the left that can be edited. So for “velocity” I turned all note velocities in the track to 127, but to no effect on the volume control change midi out . When I select “volume” from the list the editing window is empty. There must be a solution but I can’t find it. Thanks in advance for your assistance.

I guess no one is going to respond to my post and assist me, not even Lars who has responded to all of the posts posted after mine. Very disappointing after being a loyal Yamaha customer for over 40 and spending tens of thousand of dollars on Yamaha products, even a C7 Grand Piano… Guess it’s time to move on.

Hi there,
Just a thought…….have you checked Automation for the tracks in question, this is normal behaviour if the volume suddenly changes and you are unable to move the fader in the mixer as the track is playing. You can resize volume window by dragging it up.
Hope this helps.

Thank you, Mike. I tried your suggestion, but the volume window in automation is completely blank.

Have watched your faders as your track starts playing, do they suddenly jump, if so, move the track forward and press start whilst still watching the faders, if they still suddenly jump and when you try and slide the volume back up the fader is stuck, then that is definitely Automation.
Try using the pencil in the volume window and draw a point near the top of the screen……….

To correct my last post, there is no automation recorded in the editor for any track. Maybe when I originally recorded the tracks I recorded them at a specific volume and that volume is set in stone and sending out a midi volume message of that internal volume. I really can’t figure this out. I even reset all the Cubasis faders to max volume and when the song repeats the Cubasis faders remain on max, but the keyboard volume reduces for each track and the reduction is different for each track. The only fix I can think of (and I am no expert) is to stop Cubasis from sending out midi control changes, but how? Is this a Cubasis glitch?

Just saw your last post that overlapped mine. The faders do not jump and stay where I have relocated them. Only the keyboard volume changes and each keyboard zone fader is numerically reduced, ie from 127 to 52.

1 Like

Mmm🤔 this is a bit puzzling, hopefully someone else will read this thread and have an answer, I would be interested to find out what is causing this issue.
Sorry I couldn’t be more helpful.

Mike, not only have you been helpful in assisting me to isolate the problem, but you have been the only person on this forum, not even Lars, that wanted to help. I really appreciate your goodwill.

1 Like

Thank you, I will help anyone if I can, besides, we are all members of the Cubasis family, and like yourself I would appreciate any help from others too.
I do hope you manage to get it sorted though.

You wrote “ Maybe when I originally recorded the tracks I recorded them at a specific volume and that volume is set in stone and sending out a midi volume message of that internal volume”
Have you tried recording another track but with a higher volume, if so, does that level drop too🤔

Mike, I hate to admit defeat, but I give up on this. I previously mixed down the Cubasis Midi song, imported it into another iPad music app I have and it plays the keyboard back perfectly, no problem and no carried over volume control changes. I just wanted the problem resolved in Cubasis so I could continue to use it for this song. So later today I am going to delete the Cubasis version and import the Midi song from my other app into Cubasis. This should work. Thanks again.

1 Like

Sometimes when I import MIDI into Cubasis it contains Bank Select, Program Change, or other control messages. These are easy to delete.
Simply open the MIDI editor and if there’s any of that it will appear in the list on the left side. Then just select it and erase.

Thank you, belldu. The MIDI editing window to the right of the editing list is completely empty fir everything except velocity. I even changed velocity of all notes to 127 and that didn’t solve the problem. Thanks anyway for your suggestion.

Hi Mercedes CP4
This really is baffling us all :thinking:

Me too! I just re-tried other songs and the volume decrease is only with that one song. However, as of right now I have other songs that were never a problem and they are not sending out ANY MIDI notes, even though set properly. And I have had another problem I did not mention to keep issues separated. Probably 25% of the time for all songs, notes hang and I have to hit the MIDI panic button on the send track and sometimes it stops the note hanging and sometimes it doesn’t, but in every case it terminates all MIDI transmissions and I have to power down the iPad to stop the notes and then power up. Maybe there is just some conflict in my iPad, but the problems are not consistent between all Cubasis songs and I have no issues with my other apps.

About 1 hour ago I gave this answer to the same problem that belldu was having with stuck notes, he requested a Panic Button in Cubasis3, my method for stopping the stuck notes from sounding is by quickly tapping the play buttons, some AUv3 apps carry on sounding for some reason, anyway this is what I do on a regular basis and it works for me👌

Thanks. I’ll try that next time.