How to sync and record an external drum machine


I just bought the Korg Volca Beats but I’m having a hard time setting this up in Cubase 7.

I own a Focusrite Saffire Pro 40 soundcard

This is how it’s set up:


  • Project Synchonization setup
  • Timecode is set to Internal Timecode in Cubase and the Volca beats is set to Auto (you can only choose auto or internal)
  • I have selected nothing at Machine control output destination and nothing at machine control input.
  • Midi Timecode Destinations: I have selected: PRO40 Midi and selected ‘MIDI timecode follows project time’
  • Midi Clock Destinations: I have selected PRO40 Midi and also selected: ‘Midi Clock follows project position’, ‘always send start message’ and ‘send midi clock in stop mode’

A midi cable from goes from the MIDI IN of the drum machine to the MIDI OUT of my soundcard. And the drummachine is connected to a Soundcraft mixer wich goes into inputs 4 and 5 of my soundcard.

So when I press my spacebar in Cubase I see the pattern on the Korg Volca Beats working but I hear no sound in Cubase. What am I doing wrong? I hope someone can help.

Thanks a lot

You say that you see that the Volca Beast is responding to start/stop (via midi), so your synchronisation is ok.
Probably what is going wrong is the routing of your audio in to cubase/focusrite.

First thing to check is if you hear something when the volca beats is playing on it’s own. Check that first. Then you are sure that your mixer settings in the focusrite are correct.

Notice that what you hear (if you hear something) is the audio from the volca beats directly routed trough the focusrite to your speakers. This the zero latency setting, and the audio does not go in or comes not out of cubase.

Next step is setting cubase so the it can record audio from the saffire’s inputs. Under devices you can select connections, and then there is a tab “inputs”. Be sure that all the focusrites inputs are assigned there.

Next step is to create audio channels in cubase, select the correct input for the audio channels, and switch on monitoring. (little speaker buttons on the audio track)

When yellow, the monitoring lets the signal of the assigned input (see in the inspector fields) being put trough cubase. You can add efx or anything else. you can do this on the input channels in the cubase mixer of on the audio track itself

Remember that when you route the audio through cubase with monitoring enabled in cubase, that you will have to MUTE the mixer channels in your focusrite mixer or you will hear the signal twice. (one through direct routing, one through cubase a fraction later (= with a small latency)

I hope this helps a bit, these are the basics for routing in cubase, and it is something you’ll have to go through. Once you understand it completely, you’ll never forget it. It’s seems a bit complex but it isn’t and in fact it is very good to have those different routing options.

kind regards,