How to unsplit bars after xml import

After importing a piece from Sib 8, I found lots of places where the bars were split across systems as shown here.

I know this can be corrected by selecting individual barlines & inserting a system break with Shift + S, but that’s a bit time-consuming.

This is not affected whether the Layout Option that says “Allow open bars to be split across system breaks” is selected or not.

Is there a way of adjusting settings so that this doesn’t happen & whole bars are always together?
split bars.jpg

Have you tried to close the project and reopen it ? I just wrote a topic about that. It solves many problems, actually !

Ah the old ‘turn it off & then turn it on again’ trick!
Thanks for the suggestion. Just tried it but alas to no avail though.

Have you tried Edit > Reset Appearance on a COPY of the file?

Thanks - just tried that & had no luck, but doing it gave me a clue as to the possible solution.

The imported piece was originally a string quartet & I was arranging it for string orchestra and therefore adding a double bass line. The piece has several changes of time signature including an anacrusis about two-thirds of the way in, a little before the weird bar splitting occurred (this is because the piece originally had several movements, but Dorico imports the xml all into one flow). I see that the (blank) extra double bass line wasn’t following the time signatures of the other four parts, and had either no bar lines or bar lines that bore no relation to other parts. This is of course wonderful for people who want to compose in multiple time signatures etc but I think it messed up this more simple setup. What actually seemed to work was to go through the double bass line adding time signatures etc. & correcting the alignment with the other parts. Then it was OK.

I don’t know if this feature could be tidied up a bit in future updates?

Otherwise - love Dorico of course. When cues + 1st and 2nd time bars & legato expression in playback etc are sorted I’ll start using it regularly instead of Sibelius.

hi, I have a musical import from Finale that has these bars split across systems. I have tried Reset and on/off, but neither does anything. Any other things to try?

Thanks.

Have you tried to untick everything in Preferences > Xml import before you import the file?

OK, thanks. I’ll start again :frowning: