How to use a foot pedal as a controller

Hello all,

I want to be able to use a foot pedal as a controller. I’ve got one of my pedals working as a regular on off button, but I want to use my other one as a controller(a fader of some sorts). I am connecting my pedals to the BCF2000. How can I properly set up my pedal as a midi controller?

Also, how am I able to use the pedal to control track inserts? I have not found any way possible.

I’ve searched many times on the internet for help but none that helps me. Maybe I’m overlooking something.


I guess that you already made the necessary settings on your BCF2000 for your foot controller when you plugged it. This is dependent of the way the different controllers (including the two pedals connections) should be defined on your remote device. Once done, there are two possible paths to follow.

A. Using the ‘Generic remote’.
The BCF2000 most be configured in Cubase ‘Device setup’ window as a ‘Generic remote’ . It’s the first thing to do, as this device is not in the list of the predefined Remote devices and the BCF should appear in the ‘Remote devices’ used, one way or another.

Once done if it wasn’t, check that there is a line for the foot controller assignments in the top pane of the ‘Device setup’ window : If needed, add a line for it Then check that the options displayed are set accordingly to your BCF settings : status (‘Controller’), MIDI channel, address (MIDI CC number), parameter values range, flags…
Then, in the bottom pane, things get more complicated. The problem is that, by default, the only inserts controls available are switches : things like bypass, on/off, edit… It’s inherent to the way inserts work. So, as you want to use your foot controller as a continuous one, you have to define which parameter of which insert has to be controlled and this depends of the inserts used in your projects.
This is done by :

  1. Choosing in the ‘Device’ column : ‘Mixer’ or ‘VST mixer’,
  2. Choosing in the ‘Channel/Category’ one the track/VSTi on which the insert is applied,
  3. Choosing in the ‘Value/Action’ one the insert itself and the continuous parameter of it to be controlled.

Quite tedious, I admit… The best thing to do, actually, is to use templates as frameworks to avoid having to redefine the parameter controlled each time you start a new project and do the assignments for it.

B. Uising the Quick Controls’
This way is maybe more easy at first, using the ‘Quick controls’ option in the ‘Device setup’ window. I usually use these only for specific VSTi parameters, and not for the inserts applied on it, but to each his own… You first have to define, as if you were using a generic remote, the status, address, range and so on in the ‘Device setup’ window.
Then, after enabling the quick controls in the track inspector, choose the insert and the involved parameter to be controlled for one of the eight available.
Probably more straightforward and easier to set from one project to another, but basically, the same problem as for the generic remote remains : all is dependent of which track and which insert(s) are used on it for a specific project.

Good luck…

Sorry I didn’t get back to you sooner.

Cubase still doesn’t recognize my pedal. I do all the stuff correctly in the device setup but my VST still doesn’t recognize it.

How can I find quick controls? It is not an option for me in the Inspector.

Maybe if you gave System specs including specific Cubase version… :bulb:

With 6.5 (I think it was the same with 6.0.x), and guessing that you have the inspector displayed (if not, make it appear with the ‘Set up window layout’ toolbar button), just right click in the inspector and choose ‘Quick controls’ in the panels list. It should be there, whatever the Cubase 6.x version used.

About the pedal still not being recognized by your VSTi, few questions :

  1. Is it Cubase that doesn’t detect the MIDI messages or only the VSTi ?

  2. Concerning Cubase, it’s easy to check : when moving the pedal, there should be MIDI events displayed either in the transport bar or on the meter of the track itself if it’s a MIDI track. Another and more in depth way to check the incoming MIDI messages is to use as MIDI insert the ‘MIDI monitor’ plug-in which displays in real time details of these messages. You can also record, then check them using the List editor.

  3. What is the VSTi involved and how is it set in your project (Instrument/MIDI track, channel and ports used) ?

  4. Does the VSTi involved is able to recognize the MIDI CC messages the pedal is sending ? Maybe there is something to check, here… What kind of MIDI CC messages is involved ? Check again your BCF configuration : are you sure that it is set in order to send correctly the expected pedal messages ?

  5. In the preferences, ‘MIDI’ category, is the ‘MIDI Thru Active’ option activated ? Check also that in the ‘MIDI/MIDI Filter’ one, there is no filter activated that could prevent the incoming MIDI CC messages to be used.

Okay so I’ve heard that using Ctrl-NRPN is not the right selection for the faders. Is this true? Could this be my problem?

FWIW, NRPN are specific parameters that each manufacturer can implement according to his own need and they work in three (sometimes four) parts : CC99 (parameter ID1), CC98 (parameter ID2), CC6 (parameter value), (CC38 (optional complementary value)).

So, all depends of what you want to control and which parameter in it. If it is Cubase commands, you should avoid it. But if it is a VSTi or an external instrument, all depends of its MIDI implementation. At the end, my advice is to choose something like CC, controller, or something equivalent, without bothering with RPN or NRPN parameters.