How to use Amplitube with Direct Sound?

Another thing I find confusing with my UR44C:

As much as I love to use the DSP-when recording. Sometimes I just want to play around with Amplitube or similar VST (within Cubase). But, now with my new UR44C I get no processed sound unless I untick the direct monitoring via “Studio” --> “Studio Setup”–> “VST Audio Sytem” --> “Yamaha Steinberg USB Audio”. Is that correct/the best way? How to get around it?

I kind of understand that this is the way “Direct Sound works” but guess also that there might be some workaround/routing/setting etc to use?

Please help!

I never use the direct monitoring, it’s always unticked.
I also use the Controlroom so no DSPFx features for me in the Cubase tracks, I use the settings in the seperate DSP FX mixer, which for me works just fine.
Should be improved offcourse, but I don’t think Steinberg cares that much about their hardware support.

That’s how direct monitoring is supposed to work.

I kind of get that but is there any way to fast switch between Direct Monitoring and the possibility to listen to how a VST will sound on the track, prior recording?

the speakericon on the recordingtrack?

Hi,
If I unclick that speaker icon I lose all sound for the channel (when playing).
This is the same regerdless if “Direct Monitoring” is checked or not i “Studio Setup”

On my Lexicon sound card I have a knob that will blend Direct Monitoring (but withouut any DSP effects. I.e. a clean sound) and a the sound from the VST.

You might be able to set up a Macro to enable/disable Direct Monitoring (not sure honestly).
You could try turning off Direct Monitoring and then in the mixer go to the “Hardware” tab in the Rack for the input channel.
There, you can quickly select where the sound is taken from in the hardware’s channel strip. Before the DSP effects, if your going to use Amplitube or after the DSP effects if you want to use those. Not sure if that does what you asking for but try playing around with it.

If I am playing or recording with a vstinstrument(or Amplitude which I also use) I tick the speakericon. In preferences i have the recordmode set in “manual” and no direct monitoring activated in Devices. Works the best for me this way, you can always hear yourself playing with the vst included.

Hi,
Thanks!
But I guess you have delay on the input then when recording? I.e. IF you set the buffer high, you will get at very noticeable delay?

When I record with a vsti with my midi pickup I have to set the buffer at 64, no noticable latency and no audio problems.
Same when playing/recording live guitar with Amplitdue as an insert on that inputchannel, no problems at 64 buffer.
a high buffersetting is only needed for mixing, playing lots of tracks with plugins.