How to use custom click samples in Dorico?

I’ve just finished a bigger score with soloists, choir and orchestra and need to produce some demo recordings for the choir singers to sing along and practice. At least in some places where there are just sustained notes in the orchestra I need some metronome click-sounds in order to show the tempo. I tried the three click sounds that come with dorico and find all of them ear-killing horrible - especially if you have to listen to them for half an hour. I would like to use the samples I already created and shaped for this purpose, but couldn’t find out how to make Dorico switch to my sounds.
Any ideas?

Add metronome as a player (using a drum or sth) and hide it from the printed score?

Actually, now that someone asks…we have this still undocumented feature…yes, you can replace the woodblock click with your own sounds, if they adhere to a certain spec.

Here’s how to do:

  • Prepare 3 WAV files of following spec: 44.1kHz, mono, 16 bits, signed, little endian
    They can be of any length but only a maximum of 1s will get read.
  • Create the folder
    Win: C:\Users<username>\AppData\Roaming\Steinberg\DoricoBeep
    Mac: /Users//Library/Preferences/DoricoBeep
  • In that folder create a textfile called UserBeepConfig.txt
  • The UserBeepConfig.txt shall contain on 3 lines the paths to your custom click sounds. Here an example of how it looks like with me:

The sounds can also be anywhere else on your disk and named whatever you like, just give the right paths.
The specified sounds then replace the Metronome’s built-in woodblock sounds.
If you want to revert to the woodblock, simply delete or rename the UserBeepConfig.txt.
And you have to restart Dorico for the new setting to take effect.

When we find the time, we will make a nice GUI around this and more easily accessible, but don’t know when this will happen.

1 Like

Thank you Ulf for this instruction. I will give it a try tomorrow. Right no I dit a workaround by exporting the tempomap to another program and having the click samples played back, that I prefere. But of course it will be more useful to integrate the samples into dorico, substituting the sounds provided …

Are you certain your instructions work for Mac? I did everything requested and still no dice (proper WAV file naming and types, creation of folder and actual txt file document, and I confirmed the paths to where I put the WAV’s I bounced individually from Logic for the 3 clicks).

Thanks for any help -

Oh, sorry, I forgot to mention, that you have to restart Dorico for the setting to take effect. Does it then work for you?

Works for me on a Mac.


Hi all!

I just discovered this workaround/undocumented feature.
However, in my case, the selection of the custom waveform doesn’t properly export, in the exported file the click sound is reverted to the default one.

Any ideas?


Could you post your wave files? Do they adhere to the spec? (17.1 KB)

Thx, here you go!


EDIT: I just discovered that even stopping and restarting playback will revert to the default sound…

Hm, works for me with your sounds.
Did you really follow exactly my instructions?
The custom samples replace the woodblock sounds of Dorico, so in the playback options you have to choose woodblock.
Also try to restart Dorico once.

Ah Ulf, my bad…

To cut a short story long, I am downstairs because I have to watch the puppy, and on the laptop I only have SE…
I just tried running up to the studio, and Pro has the dialog you indicated!
It also seems like setting the presets inside of the Beep VST to “prog 1” and so on doesn’t do much? It’s a Cubase habit… :slight_smile:

Should be all good now, thanks a bunch!!


do you think can I use with Dorico 4 SE also? (I know I can use woodblock and HS but I can’t save a template), thanks

@R_R, I don’t know SE, does it have the dialog where you can switch to the Dorico provided woodblock sound for metronome? If so, then yes. If not, sorry, you’re out of luck.

It doesn’t, I’m afraid: Dorico SE doesn’t include the Playback Options dialog.

ok, I’ve saved empty files with my default settings including HS metronome with GM woodblock sound (unfortunately it is “tonal”),
I start new project from there and “save as”,