How would I fix this?

Quarter Notes are in voice 1 and Whole Note is in voice 2.
Note spacing.png

Maybe go to

Setup Mode: select flow: flow options: voices.

I had to delete the whole note and re-input again in voice 2. Not sure why it didn’t work the first time.
I neglected to stem up the first time.
Note spacing fixed.png

It looked like a bug as it wasn’t the same as any of the standard options.

You must have explicitly set the ‘Voice column index’ property in the Properties panel to produce that result.

Thanks, that makes sense. Now I understand the use of the column index more accurately.