How you can set up Cubase to start only with P-cores for Intel 12th, 13th gen

Hi guys,

I saw a lot complains about how poorly performs 12th and 13th gen Intel CPUs with Cubase in Windows 11. To be honest I dont have such issues by myself, but I want to share with you how you can set up Cubase to start only with P-cores. Once you make this shortcut, just start it, and Cubase will run only on P-Cores. No more hassle to disable E-cores in BIOS or set every time in Task Manager CPU affinity manually.

  1. Go to your Cubase.exe file location:
    C:\Program Files\Steinberg\Cubase 11

  2. Right click on Cubase11.exe and choose to create shortcut on Desktop

  3. Open Properties of new shortcut

  4. Copy in Target field this:

C:\Windows\System32\cmd.exe /C start “” /affinity FFFF “C:\Program Files\Steinberg\Cubase 11\Cubase11.exe”

Please be careful and use correct " symbols. (Steinberg forum automatically converts those symbols and if copy directly it will not work, you need to copy " symbol 2x times manually)

  1. Insted of FFFF value choose according to which cores you want to run:
    CPU - HEX

    0 ---- 1
    1 ---- 3
    2 ---- 7
    3 ---- F
    4 ---- 1F
    5 ---- 3F
    6 ---- 7F
    7 ---- FF
    8 ---- 1FF
    9 ---- 3FF
    10 — 7FF
    11 — FFF
    12 — 1FFF
    13 — 3FFF
    14 — 7FFF
    15 — FFFF

For example I have i7 12700K which have 8 P-cores and 16 threads. So I choose FFFF as it will allow Affinity to run only on first 16 cores which are P-cores.

  1. Click Apply button.

  2. Click on Change Icon button
    Click on Browse in opened window
    Go to C:\Program Files\Steinberg\Cubase 11 and choose Cubase11.exe
    Click Open
    Choose Cubase 11 icon in window
    Click Ok

  3. Click Apply and Ok

Now when you will launch Cubase via this new shortcut, CPU Affinity will automatically switch to your preferred core count.

Hope this will help.


This is great! Have you run any tests to see what, if any, difference this will make with regards to Cubase performance/latency?

In my case it’s easier turning of e cores in bios. I have an overclocked i91300ks and when I disable e cores and test cubase the results are not as good, especially in high track count projects. I believe ms and intel have improved thread director in the latest build of win 11 so the issues relating to this matter are, in my case anyhow, irrelevant.

1 Like

Ah, ok, thanks for sharing your experience!

And I agree, I’d rather not mess around with workarounds like this if I don’t have to (that’s Thread Director’s job) and yes, with the latest Win11 build, things are running pretty smoothly for me as well.

1 Like

Its up to you. If all works as should then leave it as is by defauld of course.
This thing do same as if you manually set CPU affinity in Windows Task Manager.

1 Like

Any news to this? Was this kinda fixed by MS?

I’m running an i7-12700 with newest build Win 11 and Cubase AI 6. Certainly an OLD version of cubase. I have BAD audio drop-out problems and just found this thread. I’m going to try the P-core shortcut described and see if it fixes drop-outs. Probably upgrade to cubase 12 after that. I intend to update this with my findings.

So I run it from the shortcut and it seems better but I’ll have to spend some more time with it as the drop-outs are intermittent and may still show-up. One thing I don’t get is the p-core, e-core, thread thing. My i7-12700 has 8 P cores, 4 E cores, and 20 threads. In Task Mngr details it shows 20 cores (???). If I want to run only P-cores why set the first 16 cores active (FFFF) and not the last 4? Why do the 8 P-cores become 16 for this purpose? Weird…

P-cores are hyperthreaded so 8 physical cores have 16 logical cores. E-cores dont have hyperthreading so they are 4 in 12700 example. P-cores are shown first - so first 16 cores are actually 8 P-cores.

I want to refer you to tis thread I started. I’ve just updated my bios and all is well!