Hub loses my latest used scores

Since 3.5 I have the problem that the hub doesn’t show my lastest used scores anymore.
I’m an MacOS 10.13.6.

Have you changed where they are located in the file structure? If you move them to a different folder, you lose them from the recent files list.

You are absolutely right. That’s the logical reason.

Hi again.
I realise that yet it is not really the problem that files were moved. I still experience that after having restarted my Mac the Hub loses files. I had counted the number of files before I restarted the computer. After the restart there were about 5 files less in the Hub. Very strange.

It can’t indeed be the problem. I’ve occasionally moved files or renamed them after they’d been saved and they still remain in the Hub. Subsequently trying to load them from the Hub results in an error message. I’ve never seen files disappear. There must be something else going on. Now I’m curious!

Actually, to contradict my earlier comment, you’re right. Happens to me too, now that I’m noticing.

But have you ever had recently opened files disappear from the Hub? I can’t remember ever seeing this or reading about it on this forum.

I can’t remember having experienced this before 3.5.
I have converted Sibelius files to XML then imported them into Dorico and after the next restart of my Mac I have lost several files in the Hub.
That’s all I can say.

There’s not a great deal of sophistication to the list of recent projects in the Hub window. When Dorico starts up, any files that are no longer at the specified location are pruned from the list, so they won’t appear there. If you move a file while Dorico is running, it remains on the list but will then be pruned if you try to open it (after telling you that it can’t be found). There’s really no other way that a file can be removed from the list, aside from you right-clicking and choosing ‘Remove from Recent Projects’ from the context menu, or choosing File > Open Recent > Clear List.

Yes I know this. It worked this way so far. But now it doesn’t anymore no matter if you believe me or not. Maybe it depends on the fact that normally an error message flashes when I shut down the Mac and let it reopen all apps which were open before the shut down. But this error was there prior to version 3.1. I ignored it because there were no other troubles with this.

Are your Dorico projects stored on a mapped drive, or on Google Drive/Dropbox/iCloud/OneDrive etc.? If the latter, is there a possibility that the connection to the cloud storage has been lost at some point, possibly because you’ve had to re-enter login credentials for that service?

Thanks for the trial to help.
No they are stored on my Samsung T5 since the days I used Dorico. That’s why I don’t understand it. It worked in former days.
But it is at least nothing to dramatic :slight_smile:

The other issue is storing files on external drives in addition to the web services as Leo mentioned. If you disconnect a drive, open dorico, and then reconnect dorico and open it again, the list, as Daniel stated, has been pruned. So once the drive is reconnected, the list is gone because the most recent time Dorico was opened the file path was broken.

No, this is not the problem. Because the external drive is my startup drive. And it did work in former days as I said. The hard drive never gets disconnected.