Hub solution?

Java http://www.oracle.com/technetwork/java/javase/downloads/index.html?ssSourceSiteId=ocomcn is not the same as Javascript http://en.wikipedia.org/wiki/JavaScript.

Okay Grand Senior Member Steve :slight_smile:
Thanks for coming in, especially after you sorted my Nano & Control Freak problems out. Respect.
I have to say, though, that is a bit of an obscure reply for a Luddite like me.
Are you suggesting I download something or look to see if I’ve got it or what? I get confused reading my own name sometimes, so I’d love you to elaborate :slight_smile:
Neil

Edit - Oh, no I’ve just seen “multi-paradigm” in the Wiki article - just off for a lie down!!

Eek. how embarrassing, this “title” due simply to the quantity of my bloviations here, not the quality, I assure you.

So to further bloviate, :wink: Javascript is a scripting language that makes it possible for web pages to do automated stuff, like logging into a website or deciding which advertisement show you. Java is a whole programming platform. here’s a website that gives an explanation- http://www.htmlgoodies.com/beyond/javascript/article.php/3470971

I can never access hub either. I do not have Java on my machine and would prefer to keep it that way. Java is notorious for various security vulnerabilities.

Is Java a requirement for hub?

—JC

No.

That’s why yer the GSM, baby. :smiley:

:slight_smile:
Square one, back to, comes to mind !!

I’d just got over “multi-paradigm” too and now “boviations” have appeared.
My brain hurts.

One day this hub thing will be resolved. Until then, perhaps I’ll use Cubase for something else, like music :slight_smile:
Or I’ll do something far more stressful, like install EWQL Symphonic Choirs & see if it works at the tenth time of asking.

At least I’m not alone with a poorly hub.

Neil

People eyeroll me a lot… complaining about stuff that can be ignored… like ‘the hub’. It can definitely be ignored.

However, #1 on the Top 10 Reasons Why… updates are slow… bugs are this… design is that?:

STEINBERG HAS LIMITED RESOURCES

Fair enough. So when I see them throwing a certain amount of time, money and MARKETING ENERGY into stuff that is not only of questionable value, but simply doesn’t work, I get upset. Not to mindlessly bash, but because I would much rather they devote their time to stuff they’re -good- at and that helps my life easier. I’m trying to encourage them to stick to their core competency: THE SEQUENCER.

You can’t have it both ways: you can’t say ‘Well it doesn’t matter much anyway. You can get the same stuff on Youtube.’ If that’s the case, then why on earth create (and market) a ‘hub’ in the first place?

This is something SB does a -lot-… what I call ‘Grand Initiatives’. Stuff that isn’t all that useful and diverts precious resources away from their core wonderfulness.

—JC

JC
Fully agree with you and I’m sure that you feel better for getting that off your chest.
However, let’s not turn this into a ranting, knocking session eh?

have a look at the reason why I posted this topic in the first place:
I had a stable, albeit old system running 4.5 on Windows XP with an old Pentium. I never even had internet access with it. It died. I couldn’t save it.
Suddenly I find myself in the world of Windows 7, all sorts of new stuff plus Cubase 7.0/7.5
Things are much different, mainly much better.
Now, I find things aren’t working such as problems with my Nano & Kenton controllers, this hub thingy and quite a few more things that are puzzling me.
I question whether it is me. Is it my new pc or its config? Is it the way I installed Cubase?
With a completely new everything, I want the peace of mind of knowing that I’ve correctly installed everything & I’m not going to settle down to a project to find I have to do some reinstalls etc etc.
So I’ve posted questions, albeit simple ones, here to ensure either I made a mistake or there’s a common problem shared by other users.
So maybe the hub isn’t important. Of course the sequencer is the most important part, but someone has replied to this saying they have hub problems too. I’m reassured that my rig is normal.

So people can eyeroll you as much as they like. I don’t judge you at all. I’m very out of touch with this community having enjoyed my little self cocooned in version 4.5 for too many years.
So please don’t judge me for seeking a solution to a problem that doesn’t interest you, purely to get the peace of mind that my rig is okay.
There’s no need to turn this particular topic into a ranting session when others are trying to help. Indeed the very fact that folks have jumped in with potential solutions has settled me down and reassured me that I’m surrounded by people willing to help. This is just another one of those little Steinberg quirks, not a self-inflicted installation problem.
That gives me the confidence to continue doing what I bought Cubase for in the first place - using the sequencer to make music.
I sincerely wish you a good day
Neil

This is a total shot in the dark, but have you looked in c:\windows\system32\drivers\etc
The lmhosts and hosts files could have been edited. But then again you would have the same problem connecting using a browser.
I had a popup blocker once happily writing to a lmhosts and add 127.0.0.1 to all URL that had a popup window.

I have never been able to connect either. I have tried everything.
Maybe Steinberg should build some troubleshooting utility or start capturing a log that will hopefully help identify the issue…

Are all the .NET up to date ? Is cubase run with Admin Rights ?

Yes and yes. Also, verified that I have the latest version eLicenser, the Windows Firewall turned off (or On with the Cubase executable allowed)

Other suggestions?

:slight_smile:

It has never worked for me either. When I see something that says it is connecting yet never does and is web-based, and I know that my Internet connection is functional, I immediately think that the thing is not resolving the DNS name that it is trying to connect with.

Luis if you are still there - what URL address and/or port and network protocol is the hub is trying to connect to/with so that I can at least test to see if it will resolve to an IP address? Does it perform any form of authentication that might be failing?

I wonder the same thing. I had continual trouble with iCPro and was told -repeatedly- that the two issues were related… which made me think they need the same port forwarding.

OR perhaps SB is so used to dealing with people who don’t know an IP address from a postal address that they assume it’s something basic like ‘no Interweb’. :smiley:

Regardless, I wish SB would be far more transparent about precisely what transport/protocols are required to get this working.

What grinds at me is that iCPro ‘magically’ started working after one ‘minor’ update… though there was no indication that anything got ‘fixed’ in that regard. Undocumented fixes do not build trust.

Have you tried a different DNS server ? Like 8.8.8.8 the Google DNS

Hello,

this may be the cause of your issue:
http://www.steinberg.net/forums/viewtopic.php?f=184&t=29600&start=100#p363788

Hope this helps!

Regards

FWIW: I use 7.5.2 64 on Win7/64. I removed QtNetwork4.dll from C:\Windows\System32, rebooted and 2 things happened:

  1. When I re-started Cubase, ALL my prefs were gone. It even asked me to register and check the audio driver. OOOPS.

  2. The hub opens, but -still- does not connect to internet.

PM me for more details. I see no reason why what I did would screw my prefs but I’m not happy about this. And yes, I was quite careful.

—JC