Hub solution?

Has anyone got a solution yet to the Steinberg Hub never connecting?
Seems like it could be a useful tool.

I was wondering if it had anything to do with firewalls perhaps or something else blocking the connection.
Seeing as I only installed 7.0 & 7.5 a couple of weeks ago, it’s a shame if there is no solution to this problem.

Interesting. I didn’t even know it was a problem as mine loads a few seconds after initially opening the hub. Sorry I dont have an answer for you. Good luck…

Which Browser(s) are you using / have you installed?
Are you using the standard Windows Firewall? Are you using a proxy?
Virus software?

I’m using Internet Explorer 11.
Windows Firewall is off.
Panda Anti-Virus Software, which has it’s own firewall.

See what happens if you temporarily switch to Windows Firewall and turn your AV off.

No luck
Tried it without AV & firewall, without Windows firewall & even turned UAC right down.
Nothing worked.

As a thought it might be related to problems with the Cubase preferences files. As Cubase rebuilds these if these are missing you could try deleting existing files and let Cubase rebuild on next load and see if it clears the issue. The only impact of this as far as I’m aware is longer loading time on the next Cubase load as it rebuild the file. I usually just rename the old file to force Cubase to rebuild to see if it solves the problem. You can then always reset things to where you were by renaming again if you wish.

There are a number of different preference files and I can’t remember them all but I think there’s a general or system set which would be most likely to be where any such settings for the hub if they exist are recorded. Anyway this is just a thought as something you could investigate. This may prompt someone with more technical knowledge to give you more details. I’m not at my Cubase computer at the moment or I’d look at the files to see if the hub is referenced in them.


Another thought, do you have any IE plugins such as google chrome or adobe toolbars etc.
If so try disabling these.
Also, I’ve been told that some users have had issues on Windows 7 after they’ve installed Firefox - even if they are not actively using it.

I disabled Google Toolbar - no luck
I also checked my firewall in Panda and that contains Cubase 7.0 & 7.5 with outbound permissions to access the internet.

Dave - good ideas but:
I initially installed 7.0 and then the 7.5 upgrade. Then I removed 7.0 (fool)
After seeing some tutorial videos for 7.0 I installed it again. I haven’t changed any preferences on this so that I can go through the tutorial videos, so I can’t see how any preference files may be corrupt.
There is a list of all the template/preference file locations in the Knowledgebase, but that’ll be a last ditch effort.
Let’s face it, the hub is a nicety you either like or dislike. I just don’t like to see it hanging there waiting to connect. It’s easier to add the links to favourites to be fair.

I have since seen another post about this somewhere - a quick search for hub will reveal it, so it is obviously an issue with other users.
I really don’t want to get into too deep technical issues as I’m becoming a bit of a Luddite as I get older so it’ll just have to be “one of those things” until a solution appears.
Not to worry folks

Some more info. Still no issues and I am using IE 11 as my default browser and I also have the latest Firefox installed and use it on occasion.

Hi Neil
Had another thought on this after having a quick look round the Cubase files.
I don’t now think the issue is linked to preferences.
However I did notice the hub seems to make use of Java script, so perhaps your java installation needs updating.


Hi Dave
That is a possibility.
Now & again I get a message (nothing to do with Cubase) that I need Java to access blah blah blah, so I may not even have Java on the music rig. I’ll check later.

Hi Neil,

please install the latest eLC:

If it still doesn’t work, please run the maintenance tasks in the eLC. Do you get any errors?


Hi Luis
and thanks for jumping in on this one.
Unfortunately it still didn’t work and no errors were reported when I ran the maintenance in the E Lc

Hi Neil,

it was worth the try. Is it the same with Cubase in 32-bit? Have you tried it?


I’ve tried it in 64 bit 7.0 and 32 & 64 bit 7.5

Hmm, also look in the Java control panel that the “enable in browser” setting is checked. :exclamation:

As mentioned earlier, I don’t have Java installed


Actually I never saw a posting with this confirmation.

No problem :slight_smile:
I’ll install it if it’s confirmed definitely that the problem is lack of Java.