Huge setback with midi modifiers since Upgrade


I’m using midi modifiers on all the tracks of my very large orchestral template to filter out of range midi notes. The reason I do this is to be able to play on the spot ensemble patches while selecting multiple tracks in Cubase. It allows me to record multiple tracks without recording high notes on the cello and low notes on the violins.

Since I updated to C11, all my tracks are now locked to a Locrian scale by default. All the tracks that contain a midi modifier now need to be reset to a “no scale” setting. “No Scale” should be the default. So please dont add features that will break our templates.

I can fix this but it’s a big waste of time. First off, figuring out what was causing the issue and second, going through all my templates to fix this is going to take forever.

Please take note of this.

Such a great idea! :bulb:

I had this problem in the very first project I opened on 11. A jam I had been working on in 10.5 I had a velocity filter on a bass line and it was now changing the notes, I pinpointed the problem to the modifier but I hadnt realised it was quantising notes to a new scale.

Yes! Freaked me right out I have to say after importing a 10.5 project - took a few mins of “WTF!?” and a bit of head scratching… same thing, MIDI Modifiers, on any track that had them enabled, set to Locrian scale adjustment… made my jazzy piano a bit toooo jazzy.
Is this the setting I will find as default when creating new MIDI/Instrument tracks I wonder? Only one way to find out…
Perhaps this is a case of Cubase being ‘hacked’ by ‘The Jazz Underground’ :slight_smile:

UPDATE - The scale is indeed set to ‘No Scale’ if I create a new MIDI/Instrument track - so this is a bug affecting ‘importing’ projects created on 10.5 (and maybe other older versions?) - a bit obscure but they need to fix this, especially for those with orchestral arrangements and potentially LOADS of tracks to manually reset.

If I needed a reason to go back to Reaper, Steinberg just gave it to me. Instead of fixing all my Cubase templates, I went and updated my Reaper templates this weekend. And right off the bat I can tell you it’s much snappier. The same relatively large orchestral templates architecture with Console 1 and VEPro on all tracks in Reaper open’s in a fraction of the time. Closing projects is as fast as closing a web browser.

Closing that particular template in Cubase would take about 2 to 3 minutes. Other stuff I missed from Reaper, Cubase simply does not compete with like track presets that respect signal routing, HiDPI support that works, key commands for everything. Reaper is not for every one and takes patience setting up but it works and the support forums are unmatched.

A lot of people will respond to this saying, “I dont have any issues whatsoever. Cubase is super stable to me”. These people dont run into bugs mostly because there workflows and templates are less extensive. It only took half a day for a bunch of power users to experience many bugs.

To me it’s a great mystery why they keep changing things which worked perfectly in previous versions (and nobody complained about).
Apart from the newly introduced bug, the new design is rather worse compared the old MIDI modifier.

Changing a dynamic item like MIDI Modifiers can be really damaging to projects. Needs to be fixed ASAP. Thanks for the heads-up.

@fbeauvaisc have you tried editing the Musical Scale Setup? Maybe deleting one entry in the list will be enough to restore No Scales in your templates?

its annoying, i have the same issue

Yes and the maintenance update did not fix it yet.