I can only have one device driver choice for sound input output?

in win10,
my cubase ai 11, audio connection- outputs- choose the only one choice: yamaha steinberg usb asio device driver, i got guitar input but i found the computer speaker has no sound output.

how to add the another device driver to let my speaker make sound?

if in the studio-studio setup-devices-asio driver-choose asio4all v2 device driver-then the computer speaker has sound output, but no
input for the ur22c.

so i have choose yamaha steinberg usb asio device driver for the ur22c to have guitar input, and also i have choose asio4all v2 device driver for my compter speaker, but it seems to me cubase did not allow to do it, i can only have one device driver choice.

is yamaha steinberg usb asio device driver only works for ur22c, but not for computer speaker output?

why in the apple logic x pro do not have this kinds of problem, but only cubase have?

Cubase always uses only one driver for audio I/O. Always.

You can configure ASIO4all to use the UR22C as input.

i use ASIO4ALL Offline Settings, but not working.

OK, so what should I do?

Why no use the UR 22 with Yamaha/Steinberg device drivers for both, your Cubase and Windows sound - input and output?

He wants to use the build in speakers… Laptop I guess…

wow - you may be right!

That would never cross my mind when doing DAW work and I’m already lugging an external audio interface. – At the very least I’d use headphones connected to the audio interface for better listening quality. :slight_smile:

I don’t understand it as well, since many laptop speakers are very limited…

1 Like

from the youtube, no one use cubase and wear a headphone?

how did they do?

so the answer may be cubase ai with ur22c only allow people to use a headphone ?

i think the apple logic pro x is much better than the cubase?

You can use the built-in sound – speakers or headphones – on Windows, at the same time as using the UR22, but you must install and configure the asio4all control panel.

On MacOS it comes to the same thing. But you configure Audio-MIDI Setup on a Mac, as opposed to asio4all on a PC.

in the cubase ai 11 studio setup, i can see the ur22c at ports i/o list, but shown inactive, so how can i switch from inactive to active for the ur22c?

in the cubase studio setup-vst system link, i set asio input for ur22c, and asio output for hd audio speaker and check the active mark, but not working, the input still came from the microphone in the pc’s sound card, not the ur22c.

now is working.

in the cubase studio setup-vst system link, i set asio input for ur22c, and asio output for hd audio speaker.

file-quit.

excute the cubase again.

it will promp for the input setting, select ur22c.

and guitar signal will go through cubase ai to the pc speaker.


so… for the first time, need to select asio4all as the device driver, and then …

in the cubase studio setup-vst system link, set the asio input for ur22c, and asio output for hd audio speaker.

quit the cubase, then excute cubase again.

cubase will prompt for missing inputs, select ur22c.


ASIO4ALL device driver can be downloaded from the internet.

before install ASIO4ALL device driver, need to select Offline Settings selection.

from google:

How to set up your interface and DAW with ASIO4ALL

Go to the Windows Start Menu and open ASIO4ALL Offline Settings.

Select your interface by clicking the button next to it. It will light up blue when selected.

Open the input/playback settings menu of your DAW and select ASIO4ALL as the input/playback device.

We told you that…

from the manual page22


Audio Connections Window
The Audio Connections window allows you to set up input and output busses.
● To open the Audio Connections window, select Studio > Audio Connections.
Inputs/Outputs Tab


i did not see the inputs tab for the cubase ai 11?

make a screen shot

only outputs tab shown.

when the cubase running, i can not use youtube?
unless quit the cubase?

for the first, i played the recording but found no sound in the pc speaker, later, i found i have to press the input montor button to off position.

if i want to have cubase running and at the same time i need to watch the youtube, i need to go to the studio setup to check the:

release driver when applications is in background.