I cant download Cubase 8


I logged into my account and tried to download the Cubase 8 from My Steinberg, download page, mac version. Everything seems to be fine, but after a while the connection drops out and safari says “you do not have permission to access the requested file” the resume doesn’t work etc. Ive tried this for 4 days now, tried different wifi locations etc. No results.

Is there a special magic to download it?


same problem here. Already contacted Steinberg :frowning:

I need to get my hands on it asap

My downloads work. Try restarting your router if you have one and use a download manager such as DownThemAll to make sure you can resume your download if you lose connection.


same problem here:

-I tried to restart the router
-downthemall gives error 404 and does not resume the download
-I tried without the download manager, the download stops after 3.1 GB
-if I try to press the download link again, the page gives the error “An error occurred while processing your request. Reference #199.c…” and I have to log in again.

Same problem here…
Is there an alternative ftp, P2P, or mirror direct link ???

Hello everyone,
I have the same problem. I tried to download the big file using Chrome directly, Chrono plugin, Internet Download Manager, JDownloader…no one plays…After 5.1 GB the download stops and is not resumeable. I tried to keep open the MySteinberg page logged on, but no way…I need the file because my original one was corrupted due to a failure of USB HDD. I have all previous upgrade/update from / version I regularly purchased. I opened also two tickets to SUpport, but no answer. A thread on this forum, but no answer…Why this file wasn’t splitted in several parts? Is there another method to download it? Please, report your experience so the Support will help us (I hope so…)

Just tried to download and it was slow, it took over 1 hour.
However the download completed.

“Slow” in 1 hour ???.. To me, it announces over 5 hours, THAT is “slow” !!!
But after near 3 hours, the download definitly stops, and it’s definitly over ! Apparently not alone in that case, but that doesn’t reassure me… :frowning:

The only way I found is to get Cubase 8.0 and after, install the 8.5 update…
Herer’s still valid links to download Cubase 8.0 (full) :


Tried with DownThemAll = success !
Good luck !

Yes slow it should not take more than 15min on my connection :slight_smile:

Hi Martingall,
thanks for the ISO links with FTP. I was sure that there was something similar. I hope to resolve so my problem (reinstall 8 version from scratch, purchase 8.5 update and install it on a new fresh SSD drive).


I’m having the same issue with Cubase Elements 8, can anyone help? I’ve been trying to dowload the .dmg file since yesterday and it’s the same problem over and over. :neutral_face: