I can't record MIDI data

I’m new to Cubase. I am having Cubase 12 on MacMini M1. I have the same problem. no sound from the keyboard when played, it shows in the level meter that the midi note is triggered. if I write midi notes in the editor I hear them. I hear when I play written notes but can’t write from the keyboard.
I f you were able to solve it kindly write back the steps you followed to hear the sound from midi keyboard. I will try it and let you know if hear when I play midi keyboard.

Hi and welcome to the forum,

Most probably MIDI Filter is enabled. Go to the Preferences > MIDI > MIDI Filter. Make sure Note (filter) is not enabled for the Record. By default only SysEx is filtered out for Record and Thru.

Other option: double-check the Studio > Studio Setup > MIDI Ports Setup. Make sure your MIDI Input port is enabled for the ‘All MIDI Inputs’, please.

Thank you Martin for your valuable reply to my query. I tried both the ways you have suggested but no sound or the connection of VST Instrument to midi keyboard. there is no indication in level meter too.
Since the installation of the Cubase 12 for my self some months back I have been struggling to record through midi keyboard.


What MIDI Input do you use, please?

Um Audio 1x1 and midismart 5 pin midi in and out to USB cables connected to USB port in MAC Mini M1. These connection are operational in Fl Studio, Studio One, Ableton Live, Logi pro X and Pro tools… I can record midi score from the midi keyboards but not in Cubase 12. I am not sure if iI have answered your query


Which Input is selected on the given Instrument Track? Is it All MIDI Inputs?

Could you please attach a screenshot of the Studio > Studio Setup > MIDI Ports Setup window?

Thank you Martin for your kind helping hand. i have attached two images one as requested by you and the other the track inspector input midi options


Is the MIDI Input in use by the MIDI Remote or another Remote Device (Quick Controls) by any chance?

Set the MIDI Inputs of all Remote Devices to Not Connected, please.

i will try