I solved a super weird issue with my Edit menu

I actually found it!!! h a p p i n e s s !!!

I’ve had this super weird issue with Cubase where I click on the Edit menu dropdown list in the main window of Cubase.
When I try to open the Edit menu instead of the menu dropping down, whatever track is selected has its name field opened?!!? WTF, right?
This has been the case for at least 2 years, maybe 5, I dunno.
I can’t expect anybody else to have this or waste their time on something like this and then it’s something stupid I’ve done. Nope.
It’s super annoying but I don’t know where to start so I move on and select a “Track” that can’t have its name edited like “VST Instruments” or something.
I noticed one day … that when I backed up my Key Commands and reverted to the default set or something then the Edit menu dropped down as usual.
So I tried back and forth a few times and sure enough, without my KC file it worked and with it then it didn’t work-
A step forward …
Fast forward to today and I had enough so knowing it could be related to the KC file I opened it in a text editor as it’s just an XML file and I started to search for “rename” and got a few hits of which one was “rename first selected track” which was part of a macro.
The macro looked kind of pointless and it’s backed up so I deleted it
AND LO AND BEHOLD now my Edit menu works hahaha!
No more extra clicks on the VST Instrument track.
I’ve tested this more times than needed to be certain beyond the shadow of a doubt that this is the culprit on my system at least.
What a relief!

Now how does this work and how are the ingredients related.
Because … computers? I dunno and I don’t care. It works!

I guess Steinberg would love to figure out why this is happaning?