I try to launch Dorico 2, it will not launch, and I have to re-install it from scratch

I still don’t use Dorico very often because it’s so buggy in my experience.

Every few weeks I try to have another go at Dorico, but usually it will not launch at all unless I re-install it from scratch. Then I can use it for awhile, but if I come back to it a few weeks later, it won’t launch unless I re-install it from scratch. I have been going along with this for many months now, purchasing the upgrade and installing updates. At present I have Dorico 2.1.0.1067.

As I use a lot of other music software on my Macintosh, I would suspect that Dorico gets damaged somehow whenever I install a new VST or AU or change those configurations. Is that why Dorico won’t just launch on its own? Is there some sort of conflict with other music software on my Macintosh?

This is intensely frustrating. It’s not reasonable that I have to re-install the program from scratch every time I want to launch it and try to learn to use it. How can I troubleshoot this and prevent this from happening?

Dear Wheat,
For what it’s worth, I never experienced the issues you have(check my signature). I hope Ulf or someone else from the team will help you solve this problem, for usually mac users are less prone to this kind of issues with Dorico.

Hi Wheat, we never heard of such a case before. Dorico does not become stale over time or does get corrupted because of installing a new VST plug-in or so.
We are more than happy to help you, but we need you to be a little more specific and provide more information.

When you say it won’t launch anymore, what happens exactly? Nothing happens at all? It launches but gets stuck at a certain point? The beachball spins?
What does the Activity Monitor indicate? Is it showing Dorico as not responding? How about the process called VSTAudioEngine2?

How about at this very moment, can you launch Dorico or is it stuck?

When I try to launch Dorico 2 Pro, I get a dialog box that says

“Dorico quit unexpectedly.
Click Reopen to open the application again. Click Report to see more detailed information and send a report to Apple.”

There are three buttons, “Ignore”, “Report…” and “Reopen”. The “Reopen” button does nothing other than repeat the same error message.

And that is it. I never see the Dorico splash screen or any indication that Dorico is launching or loading components.

The only way that I can get around this is to download the latest Dorico 2 Pro update installer from Steinberger and repeat the installation.

Then Dorico will load and run normally, for now.

At this moment I can launch Dorico normally because I re-installed it yesterday.

I would be happy to send the system crash logs to you. Where should I send them?

Please send to ‘u dot stoermer at steinberg dot de’.
Also, now that Dorico is running for you, could you please choose from the menu Help > Create Diagnostic Report? That will create a zip file on your desktop. Please also send me that one.

I have tried a few times to install Dorico 2.1.10 without success, only that I should contact you. It has occurred on previous updates also. Please advise me on the best procedure. Thank you. Otherwise wonderful programme.
Kerry

Hi Kerry, could you please be a bit more specific? What did you do and what exactly did not succeed? On what OS are you?
Normally it should be just a matter of downloading the updater, executing the updater and then everything should be ready and set.
Especially because it is just a minor maintenance update, we don’t expect any trouble during updating, because only very few files are actually exchanged.

Try to launch Dorico - the dock icon bounces briefly, then nothing else happens, If I open the force quit, I see "Dorico (not responding). Using a demo license with 2.1.? (can’t launch it to find out the exact version - but it is whatever downloaded from your site about 3 or 4 days ago.) I’m running Mojave.

Sorry you’re having problems running Dorico. Can you please find the folder “Dorico 2” in /Users/your-username/Library/Application Support/Steinberg and copy it to your Desktop, and do the same for the folder VSTAudioEngine2 in /Library/Preferences, then zip them up together and attach them here?

Try what I tried here (https://www.steinberg.net/forums/viewtopic.php?f=246&t=139123) I also had problems with Dorico not responding due to VSTAudioEngine2

I found that Dorico does eventually launch, but it takes many minutes - perhaps as long as 10 minutes to finish launching.

Requested files attached.
Archive.zip (452 KB)

Thanks for the logs. It looks to my untrained eye that it’s taking several minutes to initialise the licensing components. Are you using the USB-eLicenser dongle or do you have your license on the Soft-eLicenser, i.e. without the dongle? If you run eLicenser Control Center and let it perform its maintenance tasks, does that help at all?

Running maintenance on eLicenser seems to have resolved the problem. Thank you!

Fantastic. I’m glad you’re back up and running.

And, we’re down again. Tried to launch, after 10 minutes, it still hadn’t launched. Force quit, ran maintenance on elicenser, tried to launch Dorico again, another 10 minutes, and we’re still (not responding).

application.log:

2018-12-13 00:33:35.156 : Dorico 2.2.0 build 1108 (Nov 27 2018)
2018-12-13 00:33:35.157 : Initializing Printer Services
2018-12-13 00:33:35.227 : Got information for printer: Canon PRO-100 series
2018-12-13 00:33:35.272 : Got information for printer: EPSON XP-830 Series
2018-12-13 00:33:35.275 : Got information for printer: EPSON XP-830 Series - Fax
2018-12-13 00:33:35.279 : Initializing Core Services
2018-12-13 00:33:35.280 : Initializing Cached File Provider
2018-12-13 00:33:35.281 : Initializing Framework Services
2018-12-13 00:33:35.282 : Initializing Preferences
2018-12-13 00:33:35.283 : Initializing Preferences…done
2018-12-13 00:33:35.283 : Initializing Dorico Application Framework Services
2018-12-13 00:33:35.283 : Initializing Diagnostics
2018-12-13 00:33:35.314 : Initializing Localisations
2018-12-13 00:33:35.314 : Initializing Dorico Application Framework Services…done
2018-12-13 00:33:35.314 : Initializing Engine
2018-12-13 00:33:35.344 : Initializing Application phase 1
2018-12-13 00:33:35.344 : Initializing ScoringApp phase1
2018-12-13 00:33:35.456 : Initializing ScoringApp phase 1…done

Please try the following: Launch the eLicenser Control Center and leave it running, then start Dorico. How does it behave then?

I was able to launch Dorico with the eLicenser running. I have since re-installed my OS (Mac) and have not seen the problem recur.