I want my UR-RT4 MIDI Out to be Out, not Thru

I keep getting bitten by a problem when using my Steinberg UR-RT4 as the audio/MIDI interface into which I connect my vintage Yamaha DX7II-FD synthesizer (with E! board update I should add). To be more specific, when I select a new performance patch on the DX, the MIDI program change messages it can contain are sent to the UR-RT4, which then echoes them from the MIDI In to its MIDI Out and confuses the hell out of the DX. I assumed there would have to be some simple way to toggle the MIDI Out behavior of the UR-RT4, but I haven’t found it. Is there no way to configure the UR-RT4 MIDI Out to be an actual MIDI Out and not a MIDI Thru? Thanks in advance.

You haven’t said what software (DAW) you’re using, but you should configure “Local off” on the DX7 so that you can control everything in the software – i.e. this is not a hardware issue, or specific to the UR-RT4, it’s just the way MIDI and sequencers need to be configured.

“Local off” makes the DX7 behave like a combination of master keyboard and sound module, in other words, MIDI messages will only go to the sequencer (DAW) and not to it’s internal sound generator. The DAW (you) then decide, in software, what you want to sent, or not, to the DX7.

While it’s true I didn’t say what DAW I was using, I wasn’t using any DAW. Merely having the DX and UR-RT4 both on and connected properly (e.g., DX MIDI Out to UR MIDI In and UR MIDI Out to DX MIDI In) is sufficient to reproduce the problem. Before any software at all is involved, the UR-RT4 is echoing the MIDI data that appears on its In port to its Out port as if the Out port were in fact a Thru. I’d like that to stop. Yes, I know I can configure things in software, but I don’t always have the computer on or any software loaded.

Mmmm … I think that’s very strange for any MIDI interface to a default “thru” like that!

Nevertheless, “Local off” on the DX7 would be a workaround (although you shouldn’t have to do that).

I agree it’s strange, unwelcome even, for an interface to confuse a proper MIDI Out with a MIDI Thru instead. And I appreciate your suggestion, but it doesn’t improve matters either. The “Local off” setting means the DX ignores the notes I play on the keyboard for sake of its internal tone generators; it does nothing to stop any data from being transmitted through its MIDI Out port.

Yes, that’s what “Local off” is intended to do …

… which is also what it’s intended to do. If the UR-RT4 is really echoing everything from its MIDI IN to its MIDI OUT (i.e. working as a MIDI THRU), then everything should work exactly the same with the UR-RT4 connected as it would with the UR-RT4 disconnected and “Local off” switched off.

Perhaps someone with a UR-RT4 and using MIDI can comment?