IAC bus sync drift OSX

Here’s one I doubt anyone here can answer but here goes.

I sync Cubase 9 with Pro Tools 12 on the same machine (Mac Pro 10.13.1) using the internal IAC bus. It’s easy to use BUT after a minute or so, I notice the two apps drifting apart. (about 20ms after 2 minutes)

Obviously I can ditch the method and deploy traditional MTC with separate interfaces but i’d like to know if anyone else has had this as I like the IAC bus.



Did you try with any other Virtual MIDI Port?

i have, same thing. Steady drift over time. Could it be to do with sample rates? pT 96k - cubase 48k

Sample rates have to MATCH dude

On IAC bus? Really? They don’t with MTC…or DO they?

i’m using independent audio interfaces

Tested with both DAWs at 48k…still drifts.

  1. Make sure you have Both set to the same Frame Per Sec as well, So 30 FPS or 25 FPS, whichever, make them match.

  2. Tempo must match as well

    I pretty much just match up everything here.

  3. Logic Master/Cubase Slave in sync ten minutes, no issues

  4. StudioOnePro Master/ Cubase Slave in sync. ten min, no issues

  5. Reaper Master/Cubase Slave in sync, ten min, no issues

Syncing via IAC bus, no issues here :smiley:

Yep, everything matching, frame rate and sample rates - Cubase drifts ahead when it’s the master.

For example - at 90.000 BPM, I recorded one bar of Cubase click into PT and when you zoom in on waveform at bar 2, it’s 44 samples out!! (One plug in on session - click, unused)
With Delay Compensation off in PT, it’s 34 samples out.
With NO plugin’s at all it’s 24 samples out.

The results are IDENTICAL when Pro Tools is the master.

I just don’t get it. I honestly think the tempo’s don’t match. If so, which one is correct?!?

Could it be an interface issue? I’m using a Presonus for Cubase on a USB bus and an AVID HD i/o for Pro Tools. Maybe the only solution is to use two interfaces that can be word-locked with the PT sync i/o


Have you tried creating a new aggregate device for both under Audio/Midi setup? This gives you an option to check a box for “Drift Correction”.
Wouldn’t hurt to give it a shot.

Thanks Evertone. I tried creating a new aggregate device for Cubase and checked drift correction (couldn’t create one for Pro Tools HD i/o’s).

It was slightly better, but still a noticeable drift over a couple of minutes, much less but still not really useable. I will be changing the Cubase interface next - to one which I can connect with a master word clock to.

Determined to solve this.

Aggregate is not gonna solve this, not to mention it sums your latency setting for BOTH audio interfaces.

A common wordclock will lock the audio clocks together but you will still have the positioning issue with MTC.

ONLY other think Im doing is NOT using Protools. ALL THREE DAWS here allowed CUbase to slave and stay in sync, your issue is more than likely PRootools

Im sure youve done this as well:
Protools Settings:

  1. Setup/Peripherals/Synchronization, set MTC Generator Port to the IAC port going to Cubase
  2. Under VIEW/TRANSPORT, make sure you have Synchronization checked so it will show on your transport.
  3. On your transport, Click GEN MTC so Protools will send MTC to to Cubase for sync

Im flying blind with SheetTools as I kicked it to the curb long ago at version 8. I had issues syncing it as well with a Roland VS2480

well for those geeky enough to still be interested in what has become obsession here…

I went back to midi cabling and connected Midi out 8 into Midi in 7 on the shared midi device AMT 8. Recorded 1 bar of Cubase click into PT (interestingly it places the first click 188 samples in front of the corresponding PT bar, but who’s worried?). Looped the bar and ran the two DAWs in sync for 5 minutes.

Yep, there IS still drift. I measured it at 32ms over 5 minutes. Not good. Ran the same test with the IAC bus and it came out at 31ms!! which suggests the clocks are inconsistent, and amusingly independent. I know we’re splitting hairs here and yes, what’s 30ms to a crap drummer but that’s not what we’re about is it. Tape machines lock better than this! Maybe 90.0001 bpm in Cubase would match 90.0000 in PT

It HAS to be the software inside Cubase. I hesitate to blame Cubase over Pro Tools but that’s my feeling.

I have to think Word Clocking the two interfaces will fix this. Can’t find out yet as the only other word clockable audio device I have to hand is a MOTU 828 mk2 (firewire into thunderbolt) which the MacPro on High Sierra simply bloody REFUSES TO see, aargh. (latest drivers, security stuff all done) Strange as my MacBook pro on the same system software has no problem seeing it!


So you are actually running TWO diff DAWS on the SAME Mac and TWO diff interfaces and are wondering why its not syncing up?

Any time you loop midi out to midi in you will have a delay as well.

Good luck Dr. Fletch, Im all out on this one. As I said, ALL three DAWS I ran here with CUbase synced locked up just fine

Locking the audio clocks via wordclock for the two interfaces will lock your audio so over time they will be in sync, your transport on the other hand

I don’t see any reason why I shouldn’t achieve perfect sync with this setup. What amuses me is that two tempos supposedly identical, can be so far out.

I’ll get there this week when I can setup the clock.