iC Pro still isn't working in 64bit Win7

I haven’t been having much luck finding help with this product; let’s try again.
I have ic pro for android. I’ve tried over and over to get this working since late January and I doubt that there is anything left unsaid or untried. But here is why I’m back.
I have two versions of Win7 Ultimate running on two separate drives on my computer; one in 32bit and one in 64bit. My recording work is done in 64bit, which is why I need ic pro running in 64bit.
Last week I was on my 32bit Windows (I have a version of Cubase 7 installed there) doing something else. For curiosity, I decided to try and get the android remote working with Cubase 32bit…it worked first time I tried it; not a hitch. And what was even more amazing, I didn’t set up an ad hoc network. And I also had a USB Bluetooth adapter plugged in by mistake. It still worked perfectly. I changed over to the USB Wi-Fi adapter and it also worked just as well; no ad hoc, nothing. Yet nothing I try will get it working on my 64bit system. I’ve made sure they are the correct 64 drivers, and everything else.
So now I’m convinced that the app is working correctly in the tablet (all updates are done on the tablet) and that the Remote SKI is installed properly in Cubase 7.5 64bit. Also, why do I need ad hoc if it works fine without. I have Wi-Fi coming from my internet connection (Bell) which seems to work great in 32bit.
Any ideas???