If you have no sound in Dorico (desktop version)

This topic serves as a reference, for the case that a user comes to the forum and reports having no sound in Dorico. Then I can refer to this thread and say, have you been through these steps, and depending on the user feedback, I can then give more specific advice.

Important to note, this here does not cover the iPad version of Dorico.

So you have no sound in Dorico, right? Okay, so please follow me:

As a prerequisite, let’s shutdown Dorico completely and start up freshly.

  1. In Task Manager (Win) or Activity Monitor (Mac) does the VSTAudioEngine process turn up in the list of processes?

Is the VSTAudioEngine process marked as “not-responding”? It shall not.

  1. When you restart Dorico and the Hub window is visible, go to Edit > Device Setup, and check: is the right ASIO driver chosen, and is a stereo output pair chosen?

  2. Now in the Hub, click Create New at the top of the window, and create a new project from the Solo Piano template. You have to wait a little bit until the audio engine initialized its state: the power button in Dorico’s toolbar will turn green when it’s ready.


Not ready for playback, or project not activated for playback


Ready for playback, or project activated for playback

Double-click on the stave to shift Dorico into Input Mode; on the keyboard type Shift-B to add some more bars, e.g. 10 bars. Enable the Dorico Metronome (see pic below) and press Play. Even though you did not put in any notes, you should be able to hear the click sound of the metronome.

  1. Enter some arbitrary notes to your project. Already during input you should hear the newly input notes.

  2. Go to Play mode and in there click on the VST and MIDI tab and then press on the little e-button (see below) to bring up the HALion Sonic editor window.

The HALion Sonic window shall look similar like this:

In the first slot the Yamaha S90ES Piano should be loaded (red circled) and when clicking with the mouse on the virtual keyboard at the bottom of the editor window sound shall be heard and metering flickering (orange circled areas).

  1. If in the step before you did not hear sound, go back to the Play Mode and make sure that none of the Mute or Solo buttons are enabled, see below.

If you came here without having been directed by someone and you don’t have sound in Dorico, then open a new topic and tell us which of the steps here you took and which ones failed and which went good. Thanks!

7 Likes