IK Multimedia CSR

Saw these guys at NAMM and they said that CSR is now 64-bit compatible however, I can’t get it to work without the VST Bridge and I’ve got the latest versions installed as well as their T-Racks Custom Shop freeware that is supposed to keep everything up to date. Is anyone running CSR in 64 bit?

Thanks!

Yes.

Did you do the “restore my gear” deal in the Custom Shop?

Aloha S,

CSR still at 32 bit here.
{’-’}

Thanks Scab…yes I did the RESTORE MY GEAR function a couple of times. Just to confirm with you, I never see a completion message box when the process is complete…the UPDATING SYSTEM message box just disappears after a few seconds after beginning the process. Also, are you running the single plug-ins in Cubase as inserts and sends or through the TR CS suite in Cubase? Every project that I try and use the single plugs I get the VST BRIDGE startup message and then the small blank GUI when accessing the plug-ins. The info button on each reverb shows version 1.1.1 as well.

Thanks Curt…glad to know I’ve got company…might be a Mac thing!!! Don’t waste your time with IK support…it’s comatose!

IK M has the best support in the business imo, I have contacted them numerous time over the years (decade) and always had an immediate response that was not dropped until resolution, even if it took IK bending their own policy with regards to license renewals, transfers.

That’s not to say anything about their marketing, and their transition from 32 to 64 bit. I actually directly asked on of the reps and a 64 CSR is not in any planning stage either, they only told me that we would have the reverb internally for Sampletank.

I was hoping they could just retain/port the algos, and use a 64 bit shell just like any other reverb, I guess it’s more complicated.

Single plug-ins (see screenshot).

I’m not a Mac guy, so I probably can’t be of much help to you.

What I do know is that when I last re-installed everything from scratch on my DAW machine, I didn’t install the original version of CSR (32). Is it possible Cubase isn’t “seeing” the folder where the new versions reside? Can you locate the folder where the new versions are installed and make sure Cubase is searching that folder in it’s plug-in paths? Maybe try moving the old CSR files so Cubase doesn’t see them?
CSR Image.jpg

CSR is working for me on a Mac in 64 bit - used as a send via T-RackS CS. I didn’t bother to install the original CSR on my new MacBook Pro, but seem to remember that the 64 bit versions of the individual reverb plugins had different names to the original, after I’d updated. There’s a new version of T-RackS CS out today, so it might be worth trying that.

Thanks again guys for the info. ChrisW: I am able to run CSR in 64 bit within TR CS too but that’s not a desirable method of working especially if I only want to use the verbs…why must we use their host program to get 64-bit? What happens when you try and run CSR by itself as a send or insert…do you get the VST Bridge message as well for 32-bit operation?

Also, I downloaded TR CS 4.5 and still no 64-bit operation for the single CSR plugs.

SuStudio, since upgrading to TR CS 4.5 I am able to run the reverbs directly as inserts and sends, and in 64-bit mode (I checked the activity monitor and there’s no sign of the bridge). The 64 bit reverbs have new names though prefixed by ‘T-Racks CS’ (see attached screenshot) and are listed alongside T-Racks CS in the effects list. Have you tried deleting the old CSR VST plugins then reinstalling 4.5?
HSSE_Main__Ins__1_-T-RackS_CS_CSR_Hall_and_MixConsole-_Handel_Source_B.jpg

Thanks Chris! That’s good news but I haven’t been able to find the old plug-ins and IK has been silent on the correct procedure for removing just the CSR portion. I’ve waited 3 days for these guys to tell me the proper way to proceed and I’m getting crickets! Do you know? Would you just uninstall everything then start from a download of TR CS only? I’m thinking both versions of CSR are installed in different locations for the bridge to keep loading on me. But I’m glad it’s working for you so I’m nearly there. :smiley:

I’d be inclined to start from a download of the latest TR CS. This seems to put all available T-RackS processors into /Library/Audio/Plugin-/VST and just activates the ones you’ve purchased. I’ve only got CSR so deactivated the others from the Cubase Plug-In Information window as it was a bit annoying seeing them listed. I’ve attached another screenshot showing how they look on my Mac.

I’m pretty sure the old CSR plugins were named differently, without the T-RackS prefix - have you tried a Spotlight search?

Good luck!
Plug-in_Information.png

Thanks Chris…ok the lightbulb just went on. TR CS doesn’t overwrite (or update) the 32 bit plugs so I’ve got both versions installed as do you with the T-Racks plugs. I deactivated the 32 versions but will uninstall them as well as my T-Racks S3 legacy plugs. Stupid update really…it should have “updated” as indicated and not simply append. Thanks so much for the help Chris and others!

Glad you got it sorted!