I'm not getting this "Merge tempo from tapping"

And yes, I RTFM. :laughing:

The project tempo is set to the default 120 PBM. But the actual tempo of the material is about 1/2 that I think. I created my MIDI part and input my taps. Since the DAW tempo was 120 and my music is about 60 PBM, I guess I was inputting taps in 2/4 time. No problem. So when I select the “Merge tempo from tapping” option, I select 1/4 notes as my taps. It then always says “Tempo out of range.” :question: And the resulting tempo is half of what it was – quite slow – and my taps aren’t lining up anywhere close to the grid.

I’m not getting how to do this

:imp:

It may help to put the tempo track at a rough approximation of the song’s tempo before you get started - the closer the better in my experience, to help Cubase out.

I ultimately found that my tapping didn’t give results as good as I wanted (I tapped “with emotion” :unamused: rather than strictly on the beat), and that I needed to do the audio warp thing anyway to tidy things up afterwards. So, nowadays I just go straight to the audio warp.

I guess then that since I didn’t bother setting the project tempo to something even close to my actual tempo I’m screwed

I suppose I could export the audio of each track, start a new project with a tempo closer to what I’m actually doing, then re-import the audio, and go from there

:sunglasses:

No, it´s not necessary to do that.

I guess I was inputting taps in 2/4 time.

Well, it surely would be helpfull, to know what taps you are inputting in what time signature…

Why then does it say “Tempo out of range?”

I guess I was inputting taps in 2/4 time.



Well, it surely would be helpfull, to know what taps you are inputting in what time signature…

whether I’m in 4/4 or 2/4, if I’m tapping on the beat, doesn’t that by definition mean I’m tapping 1/4 notes? Has to!

Did you ever figure this out? I had this same problem when I “merge tempo” was a while ago. I wound up tapping the 1 on the beat skipping 2,3,4.

I was busy today, but tomorrow Saturday I’m going to take another look at it. My gut tells me the problem is that my project tempo = 120 BPM is too far from my actual tempo as defined by my taps ( ca 60 BPM) and the app can’t handle it. I bet my workaround will, uh, work :laughing:

Doug, it doesn’t matter what the fixed tempo was set at. I think you may be tapping 1/8 notes. I just opened a project, in Cubase 5.5 which I don’t think will matter, and tapped 1/4 notes, merged it to the tempo track then did the “1” of every bar. Both worked just fine. I chose in the dialogue “begin at bar start” and “1 bar” for the 1 count and 1/4 for the 1234 tapping. Both worked fine.

One thing you will have to do is all your previously recorded tracks will all have to be in linear time base mode so when you change the tempo, it will not alter their positions. This is the button on every track in the arrange window that has a note sign and when you click it, it will change to a clock sign. You want to see the clock.


Edit: had thought I did it in nuendo.

After you merge tempo from tapping, your midi event taps will not be in line with the grid. If you turn your click track on, that should be beeping in sync.

Lastly,

I found it is best to do 1 bar taps because it makes tempo track editing easier, but if there is excessive tempo drift within the bar, you’ll have to do 1/2 or 1/4.

Oh. I thought that was the whole point of doing this. I don’t need a click, I can easily play along with what’s already recorded just by feel. But I wanted to output a score of one of the tracks, and having a rough semblance of grid was the only way to do this without massive editing/tweaking.

Who would need/want a click for a piece that is rubato?

:question:

Thanks for the help, Tom

I am tapping 1/4 notes, at least as I define the tempo of the tune (whether it’s 4/4 or 2/4, I’m still tapping on every beat). I don’t understand what you mean by “I…then did the “1” of every bar.”

Also, didn’t know all the other tracks needed to be in linear mode. I don’t think the manual says anything about it? But I think THAT’S my problem here, because when I do this function, it IS changing their positions, significantly

When I wrote that I did 1/4 note tapping “1”-“2”-“3”-“4” per measure. The other way was “1” pause 234 per measure “2” pause 234. and so on…

Does that make sense?

I think you figured it out though that the time base was most likely your problem.

What I meant by that was, the midi event you made to create a tempo track… That midi tempo tap event, once you merge tempo with it will no longer work as a click. It will be out of sync. Don’t know why, but that is just my experience with it. There may be a way to keep it, but I don’t know.

Edit: just to add. I have no idea how this will affect a score. I did it in a project full of audio files.

Oh! That is what’s throwing me off – the tapping part isn’t lining up with the grid and it’s not in sync with the audio, either… I didn’t think to check the click. I bet it’s working afterall

i find if you start with a fresh Cubase project and do the merge tempo from tapping, that the “out of range” eror doesn’t occur. Dunno why.

And this is useful for fixing audio files that are unsteady tempo-wise:
Open a new CPR and import the audio file…
define the tempo of the file/project based on tapping…
bounce the audio file (which I believe sets the tempo as part of the definition for the file?)…
change the file to musical mode in the audio pool…
adjust the tempo of the project per taste…
export the mix
import the mixed file into my original project