I just updated from a beautiful working version o Cubase 6.5 . I use time stretching and pitch shift processing on a daily basis at work. And what annoys me the most is that I am only doing One single track at time not a bunch!! It is too slow on Cubase 8.5. I’ve done every thing updated to version 6.5.20 and still the same. For crying out lout Steinberg.
I have windows 10 Cubase 8.5 , and I click audio pitch shift and set processing to best quality (MPEX Poly Complex) and what do I get ??? 20 minutes waiting for a simple 3 minutes stereo track?? Steinberg WTF is going on? On Cubase 6.5 it was just a 2 minutes max wait. Time stretching is also taking forever, I could not believe it! Please HEL[P

This is the first time I need assistance in 12 years I am contacting Steinberg or using this site. Why there is no help on this issue? I am so angry because before Cubase 6. worked great now I am stuck with school work to finish

This doesn’t address you primary problem. But the update typically leaves the old version of Cubase in place and functional. You could use that until you resolve your issue on 8.5 so you can still get work done.

I have the same problem :frowning:

This isn’t the place you should go for official support. If that’s what you’re looking for you should use your MySteinberg to contact support directly: https://www.steinberg.net/index.php?id=9075&L=1

If you can’t find anyone else having this issue, there’s a very high chance that it’s an issue with your specific setup (hardware and/or settings).

I don’t have this issue, I tested it on a single 3:30 minute stereo track and doing a -12 semitone pitch shift with MPEX Poly Complex takes less than a minute. Have you tried stopping playback before applying the processing?