Import "Customize Commands" from Wavelab 7

Greetings,

Is there a way to import my “customized commands” from Wavelab 7? (Wavelab 8 > Options > Customize Commands)

I spent a great deal of time customizing all the commands to work with a specific keypad, and it’s going to take me hours to recreate them all.

Normally, WaveLab would have proposed you to do this, when first running WaveLab 8.
Else, do this:
Copy the following files (some might not exist, according to your settings):
CustomActions.dat
KeyShortcuts.dat
Keywords.dat
MidiControl.dat

From
C:\Users\YourName\AppData\Roaming\Steinberg\WaveLab 7\Preferences
to
C:\Users\YourName\AppData\Roaming\Steinberg\WaveLab 8\Preferences\

That’s great. Thanks, PG!

Ok, after copying those files, I’m now getting this message:

"Application ‘WaveLab 8’ has caused the following error:

eLicenser(s) contain(s) no valid license for this application."

It appears that I accidentally also copied UserPreferredAnswers.dat. After deleting it (and the others), it still gives me that message. Please advise.

No, copying any kind of setting can’t cause this problem.

The new problem you report, however, recall me one I had myself 2 days ago. I ignore the origin of the problem (Microsoft Windows update?). Just in case this is the same, the problem was solved as follows:

The registry key:
HKEY_CLASSES_ROOT\Wow6432Node\CLSID{E3B4B744-A654-11D3-A1A3-005004EA089A}\LocalServer32
has the default key:
C:\Program Files (x86)\eLicenser\POS\SYNSOPOS.exe

Simply add quotes to this path, as follows:

“C:\Program Files (x86)\eLicenser\POS\SYNSOPOS.exe”

If this does not work, reinstall the latest eLicenser from there:
http://www.elicenser.net/en/latest_downloads.html
But note: installing this, removes the registry change I told you above.

Neither worked.

I first check my registry and found this line instead of the one you mentioned:

“C:\PROGRA~2\ELICEN~1\POS\SYNSOPOS.exe”

I looked at that directory, and it did not contain a synsopos file.

I did find that file in the path you listed though.

So I replaced that line with your line, with quotes.

Restarted. Didn’t work.

Without quotes. Restarted. Didn’t work.

Reinstalled latest eLicenser. Opened eLicenser software and performed maintenance.

Didn’t work.

Added quotes back to registry path.

Didn’t work.

In the eLicenser software, under licensed software, all I see is Wavelab 7, no Wavelab 8.

I also tried uninstalling and reinstalling Wavelab 8 to no avail. And, of course, removing the Elicenser USB and sticking it in a different port. The Wavelab 8 license is still not showing up, and I’m still locked out of it. I have a two week project that I need to start tomorrow morning, and it looks like I’ll be doing it in Wavelab 7.

Please see with steinberg official support for the license issues.

Figured it out. Just in case anyone else has this issue…

I purchased the downloadable upgrade of Wavelab 8. According to these forums, the Elicenser should upgrade automatically. I was able to open Wavelab 8 for two days after upgrading, though I did not spend more than a total of 30 minutes in the program.

Then, Wavelab 8 would not open because of this message:

"Application ‘WaveLab 8’ has caused the following error:

eLicenser(s) contain(s) no valid license for this application."

In the Elicenser program, I noticed only a key for Wavelab 7, not 8.

To fix, I had to find the email that was sent by Steinberg when I purchased the downloadable Wavelab 8 upgrade. I copied that activation code (a different code than my Wavelab 7 code). I opened the Elicenser program and clicked the button “Enter Activation Code,” entered the Wavelab 8 code and followed the instructions. Problem solved.

To sum up, the downloadable upgrade DID NOT update the Elicenser automatically.

Good you got it solved, bu it does upgrade the eLicenser software, since that also needs to be done to have it recognize the newly released software. The activation code is something personal and can therefor never be included in a general download file.