Importing a tempo map

I’m having an issue as a new Cubase user.

I’m trying to import tempo maps via midi files. 90% of them were made in Pro Tools, others in Cubase and Logic and I have also always imported these maps with no problems into Reaper until trying to learn Cubase now.

I’ve learned to uncheck Edit / Preferences / MIDI / MIDI File / Ignore Master Track Events on Merge. I don’t know why I need to do that but it works.

What still isn’t working is that markers often import with many duplicates that are stacked vertically on top of each other, and it’s as if Cubase is inventing some because there will be markers stacked vertically on almost every single bar often with invented markers like X2. One bar might say chorus and the next prechorus while the next says chorus again, each with a duplicate below it but perhaps one duplicate randomly says X2. That exact same tempo map is a single line of ordinary unchaotic markers in Reaper.

Furthermore, once the midi is imported it also generates a large multi-foldered instance of a rack instrument HALion Sonic SE. Not only do I not want that to happen it’s a major hassle to delete because you have to first disable HALion as a rack instrument. There must be a way to prevent this from happening?

I don’t understand why this is all so difficult in Cubase when it was a breeze in Reaper. I want to continue learning this DAW can anyone please help to resolve these issues? It’s getting borderline deal breaker since I rely on tempo maps so often.

Hi,

Could you attach a screenshot and an example Tempo Map file, please?

Here’s a screenshot of the same file in Cubase and in Reaper.

I managed to solve some of my problems like the instrument rack loading by altering preferences. I cannot upload a .mid file here, hopefully this link works: https://www.mediafire.com/file/gkchcdev1ra16wy/00_Tempo_Map-Markers.mid/file

EDIT: I’m adding a second image of the Cubase file because at the beginning of the song aside from duplicate markers the markers appear fine, whereas further into the song they are incorrect and too frequent. I’ll leave the first so it clearly aligns with Reaper.



Hi,

Sorry I don’t know the source file. But isn’t Cubase correct in fact? Isn’t it so that there are 2 markers at one position, but Reaper can’t show 2 markers at one position? (Sorry, I don’t know Reaper.) What is it really written in the file?

You can see that in the “cubase tempo 2” image on bar 65 there’s a bridge and prebridge happening simultaneously? It’s definitely not supposed to be that way. The Reaper version is the only one that makes sense, however there’s no prebridge at all in it, but at least Reaper has the x2 after things indicating that they’re repeated. The Cubase one is chaos.

Preferences -> MIDI -> MIDI File -> Import Options and change the destination to MIDI tracks (or whatever you want).

I’ve looked at your example as uploaded. There are duplicate markers in it, and Cubase loads and displays them all. Reaper does not. Cubase is correct.