Importing midi drums (correct notation but wrong midi notes in Key Editor)

I’m trying to develop a workflow for my current project where I can write my midi drums in Logic and then export it (in channel 10 of course) to import into Dorico so that I can write directly over the top of my drum sounds. When I import into Dorico the notation is great but the midi values in the Key Editor are all wrong and therefore the sounds from Kontakt aren’t working at all. I changed my midi mapping in Logic to general midi and made sure all the midi notes were correct so it should work normally. Here are three screenshots so you can see my midi import settings, the resulting notation and the midi values in the Key Editor.


Could someone please help? This is driving me mad. I don’t understand why it is importing this way. It doesn’t match up with general midi mapping no? However the standard kit does seem to play back correctly for the most part. Why is the general midi not lining up with my general midi in Kontakt?

You bumped your thread within a few hours of posting it, which might be a record :slight_smile: Please don’t bump threads – though I know it can be frustrating to wait for an answer, one will eventually come!

I’m a bit puzzled by the fact that the Key Editor is showing the regular piano roll editor for pitched music rather than the percussion editor for unpitched music. Can you attach the project you’re working on, or at least an empty project that contains your custom percussion kit and your percussion map, and the MIDI file you’re importing?

Hi Daniel,

Thanks for your response. I’m very sorry about that, in a rather dramatic twist I got a bit confused about the activity log… I will be more patient next time. I hadn’t even heard of the term bumping in regards to forums before…

Here is the Dorico and Midi file. I no doubt made some silly error somewhere…

ETUDE3.dorico (1.9 MB)


With apologies for the extremely slow response, I’ve taken a close look at your MIDI file, and aside from the fact that it’s not set to channel 10 (it seems to be set to channel 1), the notes in the MIDI file certainly match up with the General MIDI percussion map (36 = bass drum, 54 = tambourine, 42 = closed hi-hat, 56 = cowbell, 38 = acoustic snare, etc.).

When I import this into a new Dorico project, I have to switch to the Advanced Editor to tell Dorico that it should map the single track in the MIDI file onto the Drum set (full) kit (since the Drum set (basic) kit doesn’t include e.g. cowbell), and this particular file also requires that the minimum quantization value be set to 32nd notes, but otherwise it imports exactly as I would expect.

After the file is imported, I get the playback I would expect with the default HSSE+HSO (Pro) playback template, and when I open the Key Editor and look at the percussion editor, I see the notes

So I believe there’s nothing wrong with the MIDI file, or indeed with how Dorico is importing it. So I think what we need to focus on is playing this back via Kontakt.

In the project you attached, the drum set staff in the second flow is set in Play mode to play back via HALion Sonic SE rather than via Kontakt, even though I can see you have instantiated Kontakt in the rack. First, select the drum set track in the track overview in Play mode, then in the Track Inspector tab on the left-hand side of Play mode, change the VST plug-in from HSSE to Kontakt. Make sure you choose the appropriate channel that corresponds to the slot/channel in Kontakt where the kit patch is loaded.

There’s one more step, which is to click the little cog button right next to the Ch. spin box in the Track Inspector panel. This opens the Endpoint Setup dialog for the Kontakt plug-in. Make sure you choose General MIDI under the Percussion Map column for the channel where your drum kit is loaded.

Wonderful! Thank you. I’ll give this a shot tonight and let you know if I have any other questions.

In the file I sent you I was going back and forth between Halion Sonic SE and Kontakt to see if it worked using another library so I would have simply forgotten to select Kontakt before sending the file, but I had tried it out with it properly selected. I had to mess around with it a bit to get it to work. I ended up simply starting a new session and inputting the drums directly into Dorico. It still didn’t work after following all the steps so I tried simply adding a piano to the score and selected Kontakt with the drum library as the VST, which worked perfectly. What really baffles me is that after I did this it somehow seemed to magically start working in the Drum Set as well. I didn’t change absolutely any settings in the meantime so I can’t quite figure out what exactly adding the piano or selecting Kontakt as the VST on the piano staff triggered to make it work. I have used several other Kontakt instruments in Dorico and have never had any such issues by the way, only with drum kits. In any case it is now working.

I think the only detail you might have missed is simply making sure that the right percussion map is chosen for the channel in which you’ve loaded your drum set in Kontakt in Dorico’s Endpoint Setup dialog.

I definitely selected the general midi percussion map on the Kontakt channel that the kit was set to. In any case it is working now and hopefully that strange technique works every time if I have the same issue again.