Importing MIDI file only

Hi folks, when I import a MIDI file into Cubase it sets up HALion to go with it. I’m sure that’s handy for some, but I’d prefer if it didn’t. I only want the MIDI file so I can use some other VSTi of my choosing.
I can’t seem to delete the instance of HALion that has been created.
Any help would be much appreciated!
Thanks, Richie

I’m really not sure why those tracks can’t be deleted. I tried and I am stuck with them too. I never used the import to Halion tracks though, it could be a bug with Cubase 12.

If you want to import MIDI files to a VST instrument track (which has a standard instrument set, but you can change it) or a MIDI track, you can change the default behaviour of the import at Edit->Preferences->MIDI->MIDI File. In the second box (import options) the second option from the bottom is a selection, you can chose »Instrument Tracks« or »MIDI Tracks« as default action, that should do it.


1 Like

Thanks guys! Much appreciated.

Ah, in case you still want to delete those automatically created Halion tracks, you can do this with Studio->VST Intruments (F11) by clicking on the Halion SE caption and selecting no VST Instrument.