Importing midi files without program change

Hi I’m new to cubase having just received the bundled cubase AI 9.5 with my new Yamaha Montage synth. I’ve successfully paired the 2 up through USB and managed to record (and play back) some midi tracks in cubase.

The problem I’m having is when I import a midi file and try to play it back via the montage it automatically switches to a different sound (performance) on the Montage… whereas I want to assign my own instruments on the synth. I assume this is caused by a program change event, but I don’t know how to disable them or stop them from being imported i the first place.

Thanks in advance

You can use the MIDI controller lane in the Key Editor to remove the program changes, or go to Preferences -> MIDI File and enable Extract First Patch, which will allow you to set the program change to off (or something else) using the Cubase Track Inspector to the left of the project window.

Cubase Artist and Pro have several features that make it much easier to remove or filter out program changes and MIDI controllers, such as the Input Transformer, List Editor, and Logical Editor.