Importing old project files ".all" et ".arr"

Hi,

I need to import some old project files (or convert them into “.cpr”). Those files end with “.all” and “.arr”, and were made with Cubase 2 (under Windows 3.1).

I read on Internet that I need to install a SX3 version to do so.

My questions:

  • Is it the only way? Is there no option in Cubase 6 to do that? I tried all options in “Files -> Import” and “Files -> Open” unsuccessfully.
  • If I have to install SX3, how do I proceed? All I find in the download section is an update that requires a previous SX3 version to be already installed.

Thanks in advance for your answers.

Cheers,

Sam.

SX3 does it. Here is a link to Steinberg FTP server:

ftp://ftp.steinberg.net/Archives/

Is it the only way? Is there no option in Cubase 6 to do that?

Nope and nope.

If I have to install SX3, how do I proceed?

After installing SX3, use the Import function to load the old .ALL and .ARR files. Save the results and reload the newly created .CPR files into C6.

Most of the old files usually come back…but there are occasions where some of the old files simply won’t load…mostly due to corruption. Short of attempting to reload them on the original software and machine and doing a MIDI machine to machine transfer, there is no way to bring 'em back.

A word of advice. I don’t know if it’s a PC issue but if SX3 crashes when you first try to launch it, take the VST Plug-ins folder and temporarily move it somewhere else. This is an issue on the Mac/Intel platform and it solves the problem.

Thank you guys for your answers.

Sorry Haraldsson, but I still can’t find the good SX3 files. In “ftp://ftp.steinberg.net/Download/Cubase_SX_3/”, I see only updates, but not the original program. And in “ftp://ftp.steinberg.net/Archives/”, there is no SX3 at all. Where can I find the Cubase SX3 program?

ftp://ftp.steinberg.net/Download/Cubase_4/Cubase_SX_3_VST_Song_Conversion/

Sorry SamGardner. I thought it was there… And thanks to thinkingcap. :slight_smile:

Ah! Not easy to find!

Thanks a lot! Will download this one and give it a try…

Cheers

Sorry, it’s me again. The installation doesn’t seem to work on my system. I have a Windows 7 64bits with Cubase 5 & 6. I can launch the first installer with compatibility mode (XP SP2), but the Syncrosoft installer stops, saying there is another process disturbing the installation. Did you experienced this problem?

I thought at first that I should stop (temporary) the service running the eLicenser, but I can’t find the service in the list. I also tried to stop my iLok (for EW librairies), but it didn’t change anything. Any clue to solve this?

This is normally because another program (Cubase 6, for example) is using - or “looking” at - the License key. In fact you should not run the Syncrosoft installer because the SX license is “built into” the Cubase 6 license, as far as I know.

You just install the SX3 and it should be ready to run.

Hi there is another thread running which is very similar in which I posted this suggestion.

This isn’t a solution exactly, but you can send the .all file (no folders, audio etc) to anyone who has a working Cubase SX2/3.

If they boot up their version and ‘Import Cubase song…’ they will get some warnings, but will be able to pass these and get to the main arrange page.

Next they save the project in the normal way and send you the new file.

Put it in your project folder and you will now be able to open the project in C4/5/6. You may have to move your audio files into the audio folder created by the later Cubase versions.

I have done this lots of times, I hope it might help.

P

Thank you for your help, guys.

@Haraldsson: I tried to skip the installation of the Syncrosoft driver, but then the initial setup also ends… It seems that I have to install this driver if I want to install SX3.

It seems so ridiculously difficult to convert these old projects. Why couldn’t they just keep this feature in the latest versions?

Anyway, to answer Parrotspain, I have hundreds of these old files. I wanted to make some cleanup myself. But to do so, I have to be able to convert them into .cpr files. Thanks anyway for the idea.

As I mentioned in that another thread - in my Win7 x64 I managed to install SX3 / SX2 / SX1.
You need to uninstall existing eLicenser and install the latest “old” License Control Center 5.4.20.01010 which can be found here http://www.elicenser.net/en/download_archives.html
Install SX3, update to latest 3.1.1 (build 944), then uninstall LCC and re-install the latest eLicenser.
Run SX3 and enjoy

I always import old .all files using SX3.

Given the number of times friends have asked me how to do this over the years, I must say I am surprised neither Steinberg or perhaps a 3rd party have written a piece of software to make this task simpler. If there were such software and reasonably priced, I am sure most people who have used those older versions of the program would buy it as a matter of course. Could be an idea for someone out there maybe :sunglasses:

I have just tried (re) installing Cubase SX3 on my Mac. I had to reinstall the latest version of eLicenser Control (eLC), because for some reason my system could dot see Steinberg License Key after the SX3 installation. But after installing the latest eLicenser Control, all is running fine.

haraldsson said

I had to reinstall the latest version of eLicenser Control

From other threads I’ve read from Mac users there seems to be a difference in the way elicenser works on the Mac compared with the PC. The process for PC definitely involves uninstalling the latest elicenser and installing the old one - and removing the dongle before SX3 installs. Johnny B Richman pointed to the old elicenser at
http://www.elicenser.net/en/download_archives.html
The only problem I had during the process was reinstalling the latest elicenser. The installation threw up an error message, I had to delete all the references to “elicenser” in App Data.

I agree with dickiedrummer - Steinberg should be making it easier to reinstall earlier versions.

Thanks zebbie. Yes, I refer only to the use of SX3 and the eLicenser Control on Mac computers.

SX3 installation problems aside…wouldn’t it be nice if Steinberg simply put the legacy importation functionality back into C6?
Wouldn’t it?

Weasel, definitely!

Ah! Thanks a lot JB Richman, your solution worked perfectly. The trick is to uninstall temporary the eLicenser, to allow SX3 to be installed. Then you can remove the Syncrosoft driver and install again the eLicenser. It makes sense! Now SX3 works along with 5 & 6.

But yeah, like Weasel, I still don’t understand why such a feature was removed from the lastest versions… To gain 2 spaces in the import menu? To lighten the main program from a few kilobytes?

Anyway, thanks everyone for your time.

Cheers

Yes it would, but SB have made it clear that this is not a simple task, and I for one would rather they spent the time getting the current feature set working as well as possible. At least they have provided a way to do it via SX3, even if it’s a bit flaky.