Impossible to change the buffer size on Mbox 3 Pro


I have a Mbox 3 Pro and it’s impossible to change the buffer size when Cubase is running. The Mbox panel says: “The buffer size control is disabled because an application is streaming audio.”

The option “Release Driver when Application is in Background” is checked in my Cubase setup, but it looks like Cubase doesn’t fully release the driver when he is in background.

The only workaround I found is to turn on my Mbox after loading Cubase. Then I have to select the Mbox driver (ASIO 64-bit) in the Device Setup panel and set the VST connections manually. By doing this, Cubase releases fully the audio driver when it is in background and the Mbox panel allows to change the buffer size. BUT, the major problem of this workaround is that I can’t use any MIDI on the Mbox when I turn it on after loading Cubase. :frowning:

Please note that this problem was also in Cubase 6.5. I was hopping that Cubase 7 would not have it… I don’t have this problem with other DAWs.

Here my setup:
Audio card: Mbox 3 Pro (driver: 1.0.19, firmware: 1.0.3)
Processor: Intel Quad-Core i7-2600K Sandy Bridge 3.4GHz
Motherboard: ASRock Z68 PROFESSIONAL GEN3 LGA 1155 Intel Z68 HDMI
RAM: 32 RAM (4x 8GB of 240-Pin DDR3 SDRAM)
Hard drive: only SSD drives (SATA 2 and 3)
Windows 7 Professional

Thank you,


That is most definitely an avid issue. I have a few interfaces and one of them is an Mbox 3. The only program that I can change the buffer size in is Pro Tools(go figure) whereas all of my other interfaces have no issues changing buffer size in any other daw except for pro tools; it requires a restart and is definitely annoying. A workaround would be to set the engine to “release asio in background” or whatever option that is in the device setup; that way when you bring the Mbox control panel to the foreground, or anything else that’s not cubase, it’ll stop streaming audio and you’ll be able to change buffer size.


Thanks for your reply. The “release asio in background” feature works only if I turn on the Mbox when Cubase is already running. But with this workaround, as I said in my first post, I cannot use any MIDI features of the Mbox… :frowning:

Thanks again,


I’m sorry about that, my phone only showed the first paragraph of your post for some reason. That’s definitely an odd issue; have you tried the avid forum to see if anyone could help?