“In all midi” resetting

Hi everybody, I’m new to the forum.
I’ve started using Cubase Pro 11 for scoring to picture a month ago. Everything is workin good but I have a really annoying problem.
I use a Komplete Kontrol S88 as a midi controller and “in all midi” in device setup needs to be turned off in order to correctly use its DAW control features. Unfortunately every time I launch Cubase the setting goes back to having “in all midi” activated for my device. I have to go in the settings and change it every time I start working. Is there a way to make this change permanent?

Thanks for your help.

Welcome ! :slightly_smiling_face:

If you use a Generic Remote definition, be sure to save it in a safe place (.xml file) : normally, Cubase should retrieve it in each further sessions. It does, here, and I have no issue : the involved controllers are always correctly set with their respective input port used…

If it doesn’t work, I suspect that there is something fishy in your preferences… :expressionless:

Hi, thank you for replying. Do you mean to add a Generic Remote on top of having the pre configured device (Komplete Kontrol s series shows up ready to go as the keyboard is compatible with Cubase) or to remove the device and only use and configure a generic remote?
What do you mean with preferences? If you mean the main preferences of Cubase I don’t think there is something wrong. I changed some minor things (not device related) when still on demo mode and never changed anything since buying the software.

Here, I don’t have the Komplet Kontrol S series appearing in the + Add device list. So, I guess that there is, either an installer that added the involved definition (maybe in the C:\Users<username>\AppData\Roaming\Steinberg\Cubase 11_64\MIDI Remote path ?), or there is a kind of “magical” recognition of the keyboard as a controller occuring via USB, with predefined settings, but I doubt it.

So, as I guess that you are using the USB connector, I’m afraid that I can’t help, as I always use “classical” (DIN) MIDI ones and set my own Generic Definitions for my two controllers several years ago. Actually, I never trusted USB for any MIDI usage…

At the end, either there is something wrong in the Komplet Kontrol S series definition or again, there is something wrong in your preferences. Sadly, and it’s a weak point of Cubase, these can sometimes get corrupt, no matter how few or many setting adjustements done. You could try to relaunch Cubase in safe mode (more details here) to see how Cubase behave without them.

EDIT : in the first case, yes, I would try to make, at least, a minimal Generic Remote definition for your keyboard and remove the predefined one, for testing purpose. It takes some time and the whole thing is rather clunky, but it works rather well, at least, for basic Cubase commands (transport, toggle commands…) : just don’t try to use NRPN messages for endless knobs - it won’t work as expected unless using a convoluted workaround…

I have an S88 and don’t have that problem. Whatever configuration I set in Midi port setup will stay that way every time I launch Cubase. Two questions: Which of the Komplete Kontrol ports are you talking about? What problems do you have if it not turned off?

This is my setup:

Thank you very much for your time. I will try the testing and of course update the post if I find a solution this way!

EDIT: Are you aware of any useful “reset” in Cubase that could force the software to re generate the files associated with this preferences?

Thank you for your answer. I’m talking about Komplete Kontrol DAW - 1 which is the one that it is supposed to stay off for “In all MIDI”. I looked a lot on the internet before posting here, but I guess it is a problem just related to my own gear and not a known bug.

How is your S88 connected - directly to your PC (…assuming that you’re using a PC, not a Mac…) or through a USB hub?

I know that I’m in the past have had problems where it depended on in which order things were started and where I must have S88 powered on before starting Cubase in order for everything to work as expected.

I can’t reproduce that problem now and I don’t know if it’s Cubase that is more flexible in current release or if my hub configuration has changed. Try to mess around with USB connections and the order you start things and see if it makes any difference.

There is a Delete program preferences option, when using the “safe mode” Cubase launching. But I would use it only if anything else has failed. Just in case : all the preferences (providing that you are under Windows) are here : C:\Users<username>\AppData\Roaming\Steinberg\Cubase 11_64.

What I do regularly, and especially after having done setting changes, is to save the whole content of it (including its subfolders) in a safe place, to be able to retrieve it in case of something going wrong : a simple copy/replace procedure to bring them back if needed. Doing this saved my a** several times in the past, as reconfiguring a whole Cubase setup is a complicated and time consuming chore.

In your case, well, I would do the same thing and try the Delete program preferences at Cubase safe mode launching, just to set aside the eventual “Preferences” cause.

After this, and if GuruGurra suggestions don’t work, I would try the generic Remote defintion option. But yes, it would also be helpful to know how your S88 is actually connected to your DAW…

[SOLVED] Hi, so I tried what both of you suggested but none of it seemed to be the problem. What I also did was try to remove and add again the device from the device setup. After three times and a couple of closing and re opening Cubase and different projects it’s seems that “in all midi” is keeping the setting I gave it. Hopefully it will hold up, but I honestly couldn’t tell what the actual problem was and why it eventually got fixed.
Thank you again for your help, it was really helpful, especially to get to know better the software when it comes to troubleshooting.