Inconsistent vertical spacing in parts

These are 2 subsequent pages of a violin part layout without any manual modification. What could be the reason for the superimposed staves on the left page, whereas the right page seems just perfect?

The only relevant thing I notice is that almost every discrepancy (except the last system) is caused by the vertical space taken by Rehearsal marks. Uou could consider using a smaller font size for those, as well as redu ing the collision avoidance space between systems (default is 1 space, you could easily reduce it to 1/2 or 1/4)
Hope it helps!

As ever, it’s hard to tell without seeing the actual project file, for your Layout Options, etc.

Are there no signposts? Can you show the view in Engrave Mode, at least?

As Marc says, the Rehearsal Marks explain some of the large gaps (though not the last one); but they don’t explain the closeness of the middle staves.

There’s something suspicious about the bottom two systems on the left page, specifically the text (?) items “solo” and “tutti”.

I wonder if at least one of them has line breaks inside it, which makes the text item “under the hood” a lot taller than it looks like it should be to the eye.

Otherwise, it’s very hard to diagnose from a picture alone, especially without system and frame fullness indicators shown (they appear in Engrave mode, and help you see how full Dorico has calculated systems/pages to be; overfull pages can result in distorted spacing).


I think you hit the nail. On the other hand the problem vanishes if I insert a manual frame break at “E” so that the page is not crowded.

can you describe what exactly caused the problem at your project?
This could help other users who search for similar problem-solving.

There was indeed a problem with an inserted text which caused the hassle (NOT the rehearsal letters!).

The immediate solution was to manually insert a frame break 1 or 2 staves “earlier”; then the spacing was more or less ok. If this is not possible (due to page turning needs) manual tweaking is the thing to do.

was the problem with the flipped “solo” playing technique (below) - or do you refer to another text?

The “solo - tutti” in this sheet is ONE text item with manual line switches in between so that the “solo” should appear above the staff and the “tutti” below. The automatic placement of the whole item above the staff obviously caused the problem.

1 Like

I would do the two text items separately. Put one on a different grid position, then you can move them to the same place (in Write mode) once they are on different sides of the staff.

1 Like

Or, if you ever really need a single text item with line breaks, disable text collision avoidance for it so it doesn’t impact vertical spacing:

1 Like

Great, thank you for the hint!

I wonder why you are not simply using the Dorico divisi feature for this part? It would handle all the solo tutti markings automatically.

I did use it, but this is an additional split within the first section for just 1 measure; I did not want another staff to show up just for this.

If you condense divisi, it should not create an extra stave.

OK, I have no experience with condensing yet, I will investigate this!

Let me please ask you about the divisi feature: Should I always change the “divisi”-“unis.” mode, e.g. also if there is just 1 measure unis.? And is there a strategy for a really automatic part layout? I had to manually arrange the staves with manual staff breaks in order to avoid unnecessary multiplication of staves, e.g. just for the first or last measure of a staff (“orphaned” divisi measures).

If your divisi passage is quite short, and/or simple (e.g. into 2 parts, with the same rhythms) then I personally don’t see anything wrong with using a single staff, voices as needed, and indications to let the performers know what to do.

Divisi is arguably most useful for where you need to notate parts on separate staves for clarity, and when you want to be able to show the divisi on a different number of staves in the score vs the part.